 版权说明

三合一汉字输入法及其软件受适用知识产权法律的保护。

本软件向最终用户免费开放，不需要注册，无任何限制。您可以自由下载、安装、使用、复制、传播、转贴本软件，但不可以破解、抄袭、反汇编本软件。未经作者书面许可，任何机构和个人不得将本软件用于任何商业目的。有好的建议或发现本软件存在缺陷，请与作者联系。

对三合一码的理论观点、研究思路、性能分析和战略目标感兴趣者，请参阅附录部分最后一节内容。

作者：刘春华

邮箱： lch@sanheyi.com

网址： http://www.sanheyi.com


 世上无难字

    世上无难字，只怕三合一。
    会用部首查字典，就很容易学会三合一。

    三合一输入法以音形码为主，音形码以词输入为主，词输入以拼音首字母为主，部首为辅；大词库（11.5万条词语），低重码，可高速盲打，满足职业打字员的速度要求。举例：
    科学 - KHXZ
    其中，K、H分别是"科"及其部首"禾"的拼音首字母，X、Z分别是"学"及其部首"子"的拼音首字母。依此类推：
    唱歌 - CKGQ（唱、口、歌、欠）
    好玩 - HNWW（好、女、玩、王）
    多字词语就更简单了！例如：
    科学家 - KXJB（科、学、家、宀）
    牵一发而动全身 - QYFS（牵、一、发、身）
    先天下之忧而忧，后天下之乐而乐 - XTXL（先、天、下、乐）

    再看三合一如何输入单字：
    始 - SNVK
    第一，先输入"始"字的拼音首字母S；
    第二，输入部首"女"的拼音首字母N；
    第三，输入余部（去掉部首后的剩余部分）"台"的第一笔折画的代码V；（注意：第三码是笔画。）
    最后，输入余部末笔部位的"口"的拼音首字母K。
    如此，"始"的编码是SNVK。这是 音形码 。
    依此类推：
    碘 - DSIB（碘、石、丨、八）
    瞰 - KMVW（瞰、目、乛、攵）
    不认识"瞰"字怎么办？就用部首"目"的首笔竖画（代码"I"）代替"瞰"的拼音首字母，如此，"瞰"的编码变成：
    瞰 - IMVW，这是 形码 ，除第一码用部首首笔代替字的拼音首字母外，其余三码与音形码完全相同。
    依此类推：
    始 - VNVK（对比音形码：SNVK）
    刿 - IDIX（丨、刂、丨、夕）
    提示：用形码输入汉字后，编码窗口会自动显示字的拼音，还可顺便认字。
    不知道部首的字又该如何？用 拼音输入 呀！例如：
    临 - LIN
    卵 - LUAN
    不知道部首又不认识的字怎样处理呢？就用 笔画输入 ：
    乜 - VV（ [image] 、乚）
    冎 - IVVV（丨、 [image] 、 [image] 、 [image] （末笔））
    还有打不出来的字吗？

    特别提示：
    三合一将音形码、拼音、笔画码和形码经科学设计成一个和谐的输入系统，四种方式融为一体，又互不干扰，不需要切换，可随心所欲、无障碍、高效率地输入汉字。（若要快速打字，请注意先将联想输入功能关闭，以免受视觉干扰。）
    学好用好三合一的关键是要熟悉汉字部首。但刚开始时不熟悉部首也不要紧，碰上任何编码疑难字时，都可随机改用拼音输入，编码窗口会自动显示汉字编码，一切问题都将迎刃而解！另外，部首不明显的汉字只是少数，绝大多数汉字的部首一目了然。
    在后面的章节中，将详细说明笔画、部首、编码和使用技巧等。


 素描三合一

    三合一码是由音形码、拼音、笔画码和形码组成的多方式、不冲突、免切换汉字输入系统，既适合中小学生使用，也适合社会各行业人员（包括专业打字员和古籍研究人员）使用，具有规范、易学、高效、通用的特点：

    ●不拆分汉字。
    ●集音形码、拼音、笔画码和形码于一体，不切换随意使用，轻松化解一切输入难题：通用字和词语，可用音形码高速输入；不认识的字，可用形码或笔画码输入，并自动提示拼音；编码疑难字，可用拼音输入，并自动提示编码；还可方便地输入常用符号。
    ●完整采用国家规范的《汉语拼音方案》、《汉字统一部首表（草案）》201个部首以及5种基本笔画输入汉字。全面执行国家有关标准和规范。
    ●与识字同步，"无级提速"：初学拼音和写字，可用拼音和笔画输入汉字；学习部首后，可随机改用音形码；掌握的部首和词汇越多，输入效率越高。学生版还可提示3500个常用字的规范笔顺。输入汉字的过程，也是学习、复习和巩固汉字部首、汉字笔顺和汉语拼音等知识的过程。
    ●采用《现代汉语规范词典》、《学生规范字典》和《中学生规范词典》等辞典的部首检字表的归部方法确定汉字部首，与查字典一致。
    ●音形码与形码主要在第一码上有区别，可同时学会。
    ●主要按照部首读音安排部首的键位，易记难忘。
    ●包括通用版和学生版，除笔画码外，两个版本的编码和输入方法完全一样。通用版应用GB13000.1字符集（20902汉字）和通用词库（约11.5万条词语，其中包括学生词库的全部词条，与学生版“无缝”连接）；学生版应用GB2312-80字符集（6763汉字，略有增加）和学生词库（约5.4万条词语，包括《现代汉语词典》、《中学生规范词典》和《现代汉语成语规范词典》等权威词典中的词条）。
    ●以音形码为主要输入方式，词为主导，大词库，低重码，可高速盲打，满足职业打字员的输入速度要求。
    ●适用于简体中文Windows98/me/2000/xp。


 安装和卸载

     一. 要求的环境
    CPU：486及以上机型
    硬盘空间：8.1～48.6MB
    内存空间：0.8MB
    操作系统：简体中文Windows 98/Me/2000/XP

    二. 软件安装
    1. 将三合一码通用版软件shy_tyb.exe或学生版软件shy_xsb.exe下载/保存在硬盘的任意位置。
    2. 双击shy_tyb.exe或shy_xsb.exe，根据提示，将默认解压在D:\（也可人工选择解压在C:\，E:\，…等），解压完毕开始安装，点击“开始”，启动安装过程，安装成功，点击“确定”，自动重启电脑（或者点击“取消”，稍后手动重启电脑）。
    3. 屏幕下边（大多在右下角）输入法菜单中将出现：三合一汉字输入法 版本2007。若无，请继续以下步骤
    ①　用鼠标右键点击屏幕右下角输入法菜单，进入输入法设置对话框。
    ②　点击添加，选择“三合一汉字输入法 版本2007”，按照提示完成安装。
    4. 若要调阅帮助文件，先选择三合一汉字输入法，用鼠标右键点击输入法状态条，可调阅帮助文件。

    三. 软件卸载
    1. 用鼠标右键点击屏幕右下角输入法菜单，进入输入法设置对话框，删除三合一汉字输入法。
    2. 手动重启电脑。
    3. 进入D:\bfsy31文件夹（软件安装时默认解压在D:\，若曾人工选择解压在硬盘的其他位置，则进入该位置的bfsy31文件夹），双击setup.exe，弹出【卸载】界面，点击"开始"按钮，启动卸载过程，卸载成功，点击“确定”，自动重启电脑（或者点击"取消"，稍后手动重启电脑）。
    4. 进入D盘，手工删除文件夹bfsy31和sy310（若软件安装时选择了解压在硬盘的其他位置，则进入该位置手工删除这两个文件夹）。


 个性设置

    用鼠标右键点击三合一码输入法状态条，调出"个性设置"对话框。

1. 联想输入
用鼠标左键点击“联想输入”为“开”时，可直接根据上文联想出相关的字或词条；“联想输入”为“关”时，即关闭联想输入功能。
    特别提示：强烈建议关闭联想输入功能，以免在使用音形码快速输入时受到视觉干扰。
2. 光标跟随
用左键点击勾选“光标跟随”时，输入法提示行为竖行显示，每个字或每个词占用一行，跟随文本光标移动；取消勾选时，输入法提示行为单一横条，所有的字、词均显示在同一行，不跟随文本光标移动。
3. 编码全提示
用左键点击勾选"编码全提示"时，在光标跟随输入方式下，逐键提示单字/词语/非汉字字符的后续码（包括学生版笔画码的12码长笔画提示码）。取消勾选时，仅逐键提示学生版笔画码的输入码后续码。
4. 子版本
用左键点击选中“通用版”时，输入法在通用版状态，应用GB13000.1字符集20902汉字、通用词库和4码长通用版笔画码。选中“学生版”时，输入法在学生版状态，应用GB2312-80字符集6763汉字（略有扩充，还可自定义基本集外的GBK字）、学生词库和学生版笔画码（8码长输入码＋12码长提示码）。
    特别提示：若“子版本”选项呈灰色，则当前版本为单一的通用版或学生版，不能选择其他版本。


功能键一览表

名 称 | 功 能 | 备 注
BackSpace | 编码删除键 | 提示行为空时，为退格键
Esc | 清提示行 |
空格键 | 直接选字 |
回车键 | 直接选择提示行首行的字、词 |
? | 模糊键（万能键） | 第1码不用
= 或 + | 翻页键 | + 或 = 循环后翻
- |  | - 循环前翻
- | 提示行 滤掉单字 |


 汉语拼音

     音形码 是三合一的主要输入方式，要学会音形码就需要掌握汉语拼音的第一个字母；如果对汉语拼音一窍不通，就只能使用 形码 和 笔画码 ，但它们只是辅助输入方式。
    碰到任何编码疑难字时，都可随机（不需要切换）改用 拼音输入 ；用拼音输入汉字后，将自动提示字的 音形码 或 形码 。


笔画及其键位

       采用横、竖、撇、点（捺）、折5类基本笔画。
     横画根据是否与其它笔画相交分别安排在两个键位上。为叙述方便，横画当与其它笔画相交时称作相交横，不与其它笔画相交时称作非交横。例如，"王"字第二笔与竖笔相交，为相交横。与其它笔画相交的提笔也属相交横，如"扌"的末笔。又如，"王"字的首笔和末笔不与其它笔画相交，为非交横。不与其它笔画相交的提笔也属非交横，如 "地"的第三笔、"氵"的末笔等。

键名 | 笔画名 | 笔 形 | 助 记
A | 相交横 | 一 | 相交横需穿过其它笔画，用尖头的A。
E | 非交横 | 一 | 非交横不需穿过其它笔画，用平头的E。
I | 竖 | 丨亅 | 竖笔与字母I形状相似。
O | 撇 | 丿 |
U | 点（捺） | 丶 |
V | 折 | 乛（乙 [image] 乚） | 折笔与字母V形状相似。

    相关主题：笔顺规则及疑难字笔顺
               笔画码（通用版）
               笔画码（学生版）


 部首及其键位

      采用国家发布的《汉字统一部首表》201部首。有些部首本身即是完整的汉字，如"日、月、水、火、山、石、田、土"等，称为成字部首，有些部首不能单独成字，如"刂、宀、阝、衤"等，称为非成字部首。
    部首的键位安排：
1. 成字部首一律采用拼音首字母。例如：
    寸C　长C　刀D　斤J　舌S　舟Z　己（已巳）J　日（曰）R
请熟悉下列部首字的读音：
     髟Bｉāo　缶Fǒｕ　酉Yǒｕ　聿Yù　　豸Zｈì　 隹Zｈｕī　艮Gèｎ
    鬲ge　　 龠yue　 厶Sī　　殳Sｈū 　豕Sｈǐ 　臼Jｉù　　耒Lěｉ
    黾Mǐｎ　　疋Pǐ　　毋Wú　 兀Wù　　　黍shu
2. 非成字部首采用三种方式安排键位
① 部分非成字部首采用其习惯名称关键字的拼音首字母。例如：
宀B 疒B 刂D 阝E 钅J 犭Q 彳R 罒S 饣S 礻S 攵W 衤Y 爫Z
非成字部首的名称采用《新编实用汉语词典》（韩敬体等编）的附录《汉字偏旁名称表》中的命名。请熟悉下列非成字部首的名称，蓝色字为关键字：
勹：包字头　　疒：病字旁　　丷：八字头　　刂：立刀
    亠：高字头　　卩：单耳旁　　阝：双耳旁　　囗：方匡
    釆：番字头　　虍：虎字头　　廴：建之旁　　丬[爿]：将字旁
    钅：金字旁　　廾：弄字底　　犭：反犬旁　　饣：食字旁
    礻：示字旁　　冖：秃宝盖　　冂：同字匡　　攵：反文
    夂：折文　　　彐：寻字头　　衤：衣字旁　　爫：爪字头
    彡：三撇　　　巛：三拐　　　癶：登字头　　：朝字边
② 3个非成字部首作形似安排，其中：
两个与字母相似：匚C、凵U
一个与成字部首相似：屮J（屮与巾相似）
③ 11个常用的非成字部首采用指定键位，需要重点记忆：
     忄（⺗）N　　亻L　　艹P　　讠A　　纟F　　灬H
    氵I　　　　　扌U　　⺮O　　冫Q　　辶[辵]V
下面的顺口溜可能有助于记忆：

    特别提示：
    旧版《新华字典》采用189个部首（第十版《新华字典》已改用201个部首），《汉字统一部首表》是201个部首。熟悉旧版《新华字典》部首的用户应该注意增加的部首，例如：匕、长C、鼎、而、飞、非、干、龟、高、鬲G、鼓、黄、韭、隶、齐、肉、生、色、首、黍Ｓ、无、香、牙、龠Ｙ、支、至，还有C（朝字边）癶D（登字头），等等。此外，旧版《新华字典》采用的一些部首不在201部首之列，例如："其、二、用"等不再是部首。

相关主题： 部首键位一览表
               部首键位笔画排序检索表
               如何确定汉字部首


 音形码

    音形码是主要输入方式，可以输入单字和词语。音形码可输入日常通用汉字（约7000字）。
(1) 单字输入
    用音形码输入一个汉字后，在编码窗口自动提示字的拼音。
    音形码将汉字分为部首字和非部首字。部首字是指本身即为部首的字，如口、立、马、女、皮、欠、日、食、土、文，等等，否则为非部首字。
    音形码不拆分汉字，按照规范的拼音、部首和笔顺取4位等长码（不足4码按空格键结束）。
    编码方法：
    ① 部首字：首音（即拼音首字母）、首笔、次笔、末笔。举例：
    鱼 - YOVE 首音Y、首笔撇O、次笔折V、末笔非交横E
    ② 非部首字：首音、部首、余部首笔、余部末位码。（注意：第三码是笔画。）余部指一个汉字除部首外的剩余部分。余部末位码在余部末笔部位取码，如果末笔部位也是一种部首，取该部首，否则取末笔。举例：
    输 - SCOD 首音S、部首车C、余部"俞"首笔撇O、余部末位码D（余部末笔"亅"所在部位是"刂"，也是一种部首）。
    码 - MSVM 首音M、部首石S、余部"马"首笔折V、余部末位码M（余部末笔"一"所在部位是"马"，也是一种部首）。
    施 - SFOV 首音S、部首方F、余部首笔撇O、末笔折V（余部末笔"乚"所在部位是"也"，不属于部首，故取末笔）。
    再举几个特殊字的例子：
    域 - YTAG 首音Y、部首土T、余部"或"首笔相交横A、余部末位码G（戈）（余部末笔点所在部位为"戈"，也是一种部首——注意：余部"或"的末笔是"戈"上的点）。
    欧 - OQEC 首音O、部首欠Q、余部"区"首笔非交横E、余部末位码C（匚）（余部末笔折所在部位是"匚"，也是一种部首——注意：余部"区"的末笔是折）。
    痼 - GBIF　首音G、部首疒B、余部"固"的首笔为竖I、余部末位码F（囗）（余部末笔非交横所在部位是方框"囗"，也是一种部首——注意：余部末笔即是方框“囗”的最后一笔，这里的"囗"，不是“古”的下半部分“口”）。
    提示：请细心体会"域、欧、痼"三个字的编码方法，它们充分体现了三合一不拆分汉字，以及将编码建立在规范的部首、笔顺等汉字基础知识之上的特点。当然，这类字为数不多，绝大多数汉字的编码可以说是一目了然。例如：哪NKVE、竖SLIY，等等。

(2) 词语输入
    二字词依次取每个字的前两码；三字词依次取三字的第一码和末字的第二码；四字以上词语依次取前三字和末字的第一码。举例：
    键盘 - JJPZ 键、钅、盘、舟
    计算机 - JSJM 计、算、机、木
    反其道而行之 - FQDZ 反、其、道、之
    科学技术是第一生产力　-　KXJL 科、学、技、力

    特别提示：音形码是主要输入方式，可快速盲打，但要先关闭联想输入功能，以免受到视觉干扰。


 形码

      形码是辅助输入方式，只输入单字，不输入词语。形码可输入字库中所有汉字（通用版是20903字）。
    用形码输入一个汉字后，在编码窗口自动提示字的拼音，可识读不认识的字。
    与 音形码 类似，形码也将编码汉字分为部首字和非部首字。
    形码也不拆分汉字，按照规范的部首和笔顺取4位等长码（不足4码按空格键结束）。
    编码方法：
    部首字：依次取字的前三笔和末笔（与通用版 笔画码 同形）。举例：
    鱼 - OVIE 首笔撇O、次笔折V、三笔竖I、末笔非交横E
    魚 - OVIU 首笔撇O、次笔折V、三笔竖I、末笔点U。
    非部首字：将音形码的第一码首音（拼音首字母）替换成部首首笔即是形码，即依次取部首首笔、部首、余部首笔，最后在余部末笔部位取末位码，如果末笔部位也是一种部首，取该部首，否则取末笔。举例：
    输 - ACOD 部首首笔相交横A、部首车C、余部首笔撇O、余部末位码D（末笔部位是"刂"，也是一种部首）。（对比 音形码 ：输SCOD）
    刿 - IDIX 部首首笔竖I、部首刂D、余部首笔竖I、余部末位码X（夕）
    骘 - VMVO 部首“马”的首笔折V、部首马M、余部“陟”的首笔折V、末笔撇O（余部末笔"丿"所在部位不属于部首结构，故取末笔）。
    注意：非部首字中有少数字的部首属单笔画，例如，"临"的部首为单笔画"丨"，"叆"的部首为"一"，等等。由于单笔部首只能取1码（多笔部首取"部首首笔、部首"共2码），要在余部多取一笔，编码方法变为：
    非部首字中的单笔部首的字：依次取部首、余部首笔、次笔和余部末位码。举例：
    叆 - EEVY 部首非交横E、余部首笔非交横E、次笔折、余部末位码Y（末笔部位是"又"，也是一种部首）。


 笔画码（通用版）

      笔画码是辅助输入方式，只输入单字，不输入词语。通用版笔画码可输入部首字以及部首不明显的字。部首明显的字不能用通用版笔画码输入。
    用笔画码输入一个汉字后，自动提示字的拼音。
编码方法：依次取字的前三笔和末笔。举例：
繛 - AAII 相交横、相交横、竖、竖
東 - AIVU 相交横、竖、折、点（捺）
氵 - UUE 点、点、非交横（提）
嫠 - AAIA 相交横、相交横、竖、相交横
特例：单笔画编码重复4次。例如：
丨 - IIII 竖、竖、竖、竖

相关专题： 笔画及其键位
               笔顺规则及疑难字笔顺
               笔画码（学生版）


 笔画码（学生版）

      笔画码是辅助输入方式，只输入单字，不输入词语。学生版笔画码可输入3500个常用字、部首字以及部首不明显的字。不属于3500个常用字而又部首明显的字不能用学生版笔画码输入。
    用笔画码输入一个汉字后，在编码窗口自动提示字的拼音。
    编码方法：依次取字的前八笔画。不足八画按空格键结束。举例：
汉 - UUEVU 点、点、非交横（提）、折、点（捺）
字 - UUVVIA 点、点、折、折、竖、相交横
编 - VVEUVEOI 折、折、非交横（提）、点、折、非交横、撇、竖
码 - EOIVEVVE 非交横、撇、竖、折、非交横、折、折、非交横
阝 - VI 折、竖
嫠 - AAIOUOEO 相交横、相交横、竖、撇、点（捺）、撇、非交横、撇
特例：单笔画编码重复4次。例如：
丿 - OOOO 　撇、撇、撇、撇
    如果在" 个性设置 "中选择了"编码全提示"，除前8画输入码外，还将自动显示后续12画，方便学生掌握常用字的规范笔顺。前8画输入码与后续12画提示码之间用"-"分界，后续笔画提示码不能用于输入。举例：
    孵 - OVUOVIUO-UUOVIA
    噩 - EIIVEIVE-AIVEIVEE

    相关专题： 笔画及其键位
           笔顺规则及疑难字笔顺
           笔画码（通用版）


 拼音输入

      拼音输入是辅助输入方式，只输入单字，不输入词语。拼音可输入字库中所有汉字（通用版是20902字，另加特殊字“○”，拼音ling）。
拼音输入，即是按照《汉语拼音方案》输入汉字的汉语拼音。用拼音输入一个汉字后，在编码窗口自动提示字的音形码或 形码 。


 字简码

    字简码用于输入高频字。用简码输入时要加打空格键。
1. 一级简码字：拼音首字母（红色字为非规则简码字）
    都A　不B　从C　的D　而E　副F　个G　和H　时I
    就J　可K　了L　没M　你N　大O　怕P　请Q　人R
    是S　他T　又U　为V　我W　小X　有Y　在Z
2. 二级简码字：四种编码方式
①拼音首字母、首笔
    按AA　安AU　百BE　边BV　长CO　出CV　得DO　对DV
    额EU　非FI　防FV　光GI　各GO　给GV　很HO　好HV
    据JA　及JO　即JV　口KI　看KO　孔KV　买MV　年NO
    平PE　陪PV　其QA　取QE　千QO　强QV　任RO　弱RV
    所SO　属SV　条TO　她TV　无WE　围WI　尾WV　想XA
    下XE　向XO　限XV　也YV　做ZO　子ZV
②首笔、拼音首字母
    本AB　成AC　达AD　赴AF　较AJ　克AK　来AL　某AM
    若AR　十AS　太AT　未AW　喜AX　越AY　者AZ　比EB
    到ED　否EF　更EG　还EH　开EK　两EL　面EM　破EP
    天ET　现EX　要EY　再EZ　暗IA　别IB　此IC　当ID
    罚IF　国IG　回IH　旧IJ　哭IK　量IL　明IM　内IN
    跑IP　且IQ　上IS　同IT　旺IW　县IX　因IY　中IZ
    八OB　处OC　等OD　反OF　公OG　会OH　九OJ　科OK
    每OM　您ON　偏OP　全OQ　入OR　使OS　贪OT　往OW
    象OX　用OY　自OZ　被UB　次UC　斗UD　方UF　该UG
    话UH　讲UJ　快UK　六UL　慢UM　泥UN　旁UP　前UQ
    让UR　说US　它UT　问UW　性UX　应UY　这UZ　办VB
    除VC　队VD　费VF　改VG　红VH　经VJ　练VL　妈VM
    能VN　骗VP　群VQ　忍VR　书VS　通VT　慰VW　线VX
    以VY
③首笔、次笔
    先OA　后OO　少IO
④非规则简码
    万AE　或HI　但IR　着VK　最VZ
3. 三级简码字：音形码规则编码的前3码
    瘪BBO　绊BFU　褒BGO　柄BME　捕BUA　拨BUV　斑BWU
    辩BXU　背BYI　鲍BYO　刺CDA　催CLI　椿CMA　粗CMI
    策COA　菜CPO　掣CSO　搀CUO　兑DBI　蝶DCA　鼎DIV
    端DLI　嫡DNU　狄DQU　掸DUU　叠DYV　娥ENO　奉FAA
    繁FFO　钒FJO　傅FLA　寡GBE　贵GBI　勾GBV　剐GDI
    锅GJI　龚GLA　闺GMA　杠GME　阁GMO　肛GYE　涵HIV
    唬HKI　哗HKO　骇HMU　晃HRI　井JAA　棘JAI　疽JBI
    阶JEO　聚JEV　绢JFI　巾JIV　竟JLI　假JLV　睛JMA
    驾JMV　鹃JNI　嫉JNU　净JQO　兢JSI　拣JUA　攫JUI
    抉JUV　鲸JYU　颈JYV　眶KME　垮KTA　扩KUU　谰LAU
    聆LEO　戮LGV　滥LII　咙LKA　骡LMI　粱LMU　砾LSO
    挛LSU　拢LUA　零LYO　麦MAA　沫MIA　皿MIV　瞄MMA
    糜MMU　姆MNV　墓MPI　茫MPU　膜MYA　霉MYO　尿NSI
    挪NUV　脓NYU　啪PKA　盼PMO　砒PSE　霹PYV　酋QBE
    龋QCO　曲QIV　祈QSO　翘QYA　儒RLE　赡SBO　爽SDO
    涉SII　史SIV　势SLA　骚SMV　舌SOA　氏SOV　砷SSI
    述SVA　鳃SYI　颂SYO　帖TJI　眺TMO　躺TSI　褪TYV
    纬WFA　惋WNU　宵XBI　险XEO　烯XHO　汹XIO　锈XJO
    袭XLU　姓XNO　循XRO　屑XSI　腥XYI　酗XYO　羞XYV
    宇YBE　辕YCA　愿YCO　酉YEI　耶YEV　亦YGO　油YII
    泳YIU　曰YIV　哑YKE　佯YLU　驭YMV　姨YNA　妖YNO
    鱼YOV　猿YQA　岳YSO　羊YUO　友YYA　瘴ZBU　蛰ZCA
    蛀ZCU　紫ZFI　纸ZFO　滞ZIA　泽ZIV　壮ZJA　咒ZJI
    盏ZMA　盅ZMI　眨ZMO　爪ZOO　砖ZSA　祝ZSI　窄ZXO
    醉ZYU　孜ZZO

    提示：三级简码字均为音形码中不排首位的重码字。

    相关专题： 词简码


 词简码

    词简码用于输入高频词。用简码输入时要加打空格键。
1. 二字词一级简码：依次取二字的拼音首字母
2. 二字词二级简码、三字词简码：由用户自定义，详见 其它技巧 。

    二字词一级简码表
Ａ　爱国ag 爱护ah 安排ap
Ｂ　爸爸bb 保持bc 不但bd 办法bf 不过bg 变化bh 比较bj 包括bk 不论bl
    部门bm 不能bn 不怕bp 并且bq 别人br 表示bs 不同bt 保卫bw 必须bx
    不要by 帮助bz
Ｃ　翅膀cb 常常cc 彻底cd 充分cf 超过cg 窗户ch 参加cj 参考ck 除了cl
    充满cm 才能cn 产品cp 从前cq 承认cr 产生cs 春天ct 成为cw 出现cx
    采用cy 创造cz
Ｄ　代表db 到处dc 得到dd 地方df 大概dg 大会dh 大家dj 打开dk 大量dl
    多么dm 大娘dn 打破dp 当前dq 当然dr 但是ds 冬天dt 党委dw 东西dx
    对于dy 斗争dz
Ｅ　恩爱ea 恩赐ec 而今ej 而且eq 而是es 额外ew
Ｆ　发表fb 非常fc 反对fd 反而fe 方法ff 法规fg 发挥fh 附近fj 副刊fk
    分量fl 方面fm 妇女fn 分批fp 父亲fq 法人fr 发生fs 法庭ft 服务fw
    发现fx 反映fy 发展fz
Ｇ　干部gb 贯彻gc 规定gd 广泛gf 改革gg 光辉gh 国家gj 赶快gk 管理gl
    革命gm 姑娘gn 公仆gp 过去gq 个人gr 告诉gs 共同gt 各位gw 关系gx
    关于gy 工作gz
Ｈ　何不hb 火车hc 活动hd 恢复hf 合格hg 很好hh 环境hj 何苦hk 后来hl
    后面hm 怀念hn 和平hp 红旗hq 忽然hr 还是hs 回头ht 好象hx 会议hy
    或者hz
Ｊ　基本jb 坚持jc 觉得jd 进而je 解放jf 经过jg 计划jh 经济jj 艰苦jk
    建立jl 局面jm 今年jn 就怕jp 加强jq 进入jr 技术js 今天jt 觉悟jw
    进行jx 经验jy 接着jz
Ｋ　可爱ka 开办kb 开创kc 扩大kd 克服kf 客观kg 开会kh 科技kj 可靠kk
    考虑kl 楷模km 可能kn 可怕kp 空气kq 客人kr 可是ks 课堂kt 可望kw
    科学kx 可以ky 开展kz
Ｌ　老板lb 立场lc 领导ld 立法lf 两国lg 落后lh 了解lj 立刻lk 理论ll
    里面lm 连年ln 老婆lp 力气lq 例如lr 历史ls 骆驼lt 另外lw 路线lx
    利用ly
Ｍ　明白mb 每次mc 目的md 每逢mf 每个mg 棉花mh 面积mj 门口mk 美丽ml
    秘密mm 每年mn 没谱mp 目前mq 每人mr 马上ms 明天mt 明文mw 明显mx
    没有my 民族mz
Ｎ　内部nb 农村nc 难道nd 能够ng 您好nh 年纪nj 宁可nk 努力nl 你们nm
    哪能nn 哪怕np 年轻nq 内容nr 那时ns 难题nt 那些nx 那样ny 脑子nz
Ｐ　普遍pb 排除pc 平等pd 皮肤pf 苹果pg 破坏ph 平均pj 贫困pk 评论pl
    拼命pm 批评pp 脾气pq 平日pr 评审ps 普通pt 盼望pw 培训px 培养py
    品种pz
Ｑ　全部qb 清楚qc 取得qd 起飞qf 全国qg 气候qh 前进qj 情况qk 起来ql
    全面qm 青年qn 强迫qp 亲切qq 亲热qr 其实qs 其他qt 欺侮qw 情绪qx
    其一qy 群众qz
Ｒ　热爱ra 若不rb 如此rc 若得rd 然而re 如果rg 然后rh 人家rj 人口rk
    热烈rl 人民rm 容纳rn 热情rq 仍然rr 认识rs 任务rw 人心rx 容易ry
    认真rz
Ｓ　随便sb 生产sc 适当sd 十分sf 事故sg 时候sh 世界sj 深刻sk 胜利sl
    说明sm 少年sn 水平sp 事情sq 虽然sr 事实ss 身体st 所谓sw 实现sx
    所以sy 甚至sz
Ｔ　特别tb 提出tc 特大td 头发tf 提高tg 谈话th 条件tj 痛苦tk 讨论tl
    他们tm 头脑tn 突破tp 天气tq 突然tr 同时ts 探讨tt 特务tw 同学tx
    同样ty 同志tz
Ｗ　外边wb 完成wc 伟大wd 无法wf 我国wg 文化wh 忘记wj 违抗wk 无论wl
    我们wm 未能wn 文凭wp 完全wq 无人wr 无数ws 问题wt 唯物ww 文学wx
    文艺wy 文章wz
Ｘ　细胞xb 形成xc 许多xd 幸福xf 效果xg 喜欢xh 先进xj 幸亏xk 下来xl
    消灭xm 性能xn 选派xp 下去xq 显然xr 形势xs 相同xt 希望xw 学习xx
    需要xy 现在xz
Ｙ　一般yb 因此yc 应当yd 因而ye 衣服yf 应该yg 以后yh 已经yj 依靠yk
    以来yl 阴谋ym 以内yn 压迫yp 要求yq 要人yr 以上ys 因为yw 有些yx
    由于yy 严重yz
Ｚ　准备zb 政策zc 知道zd 政府zf 中国zg 最后zh 自己zj 召开zk 这里zl
    怎么zm 在内zn 作品zp 正确zq 责任zr 知识zs 昨天zt 作为zw 这些zx
    主要zy 正在zz

    相关专题： 字简码


非汉字字符码

      非汉字字符码用于输入常用的符号和字母，为3位码长（另加空格键），按字符的汉语名称以类似于 音形码 的方式编码：
二字名：依次取两个字的第1码和末字第2码。举例：
÷ - CHK（除号：除、号、口）； β - BTT（贝塔：贝、塔、土）
三字名：依次取各字第1码。举例：
∞--WQD（无穷大）； ℃--SSD（摄氏度）
下面列出非汉字字符码的全部码表，其中"参考名称"可用于记忆编码。

符号 | 编码 | 参考名称
！ | thk | 叹号
＂ | syh | 双引号
＃ | smh | 数码号
￥ | hbf | 货币符
％ | bfb | 百分比
＆ | blf | 并列符
＇ | sdf | 声调符
（ | zyk | 左圆括
） | yyk | 右圆括
＊ | xhk | 星号
＋ | zhk | 正号
－ | fhk | 负号
． | xsd | 小数点
＜ | xye | 小于
＝ | dhk | 等号
＞ | dye | 大于
？ | whk | 问号
＠ | syf | 商用符
［ | zfk | 左方括
＼ | fxx | 反斜线
］ | yfk | 右方括
＾ | jtu | 箭头
＿ | xhx | 下横线
｀ | sdf | 声调符
｛ | zhk | 左花括
｜ | sxf | 竖线
｝ | yhk | 右花括
￣ | shx | 上横线
· | jgd | 间隔点
ˉ | ype | 阴平
ˇ | sss | 上声
¨ | byf | 变音符
〃 | xtf | 相同符
々 | cff | 重复符
— | pzh | 破折号
～ | sfw | 数范围
‖ | ssx | 双竖线
… | slh | 省略号
‘ | zdy | 左单引
' | ydy | 右单引
“ | zsy | 左双引
” | ysy | 右双引
〔 | zlj | 左六角
〕 | ylj | 右六角
〈 | zds | 左单书
〉 | yds | 右单书
《 | zss | 左双书
》 | yss | 右双书
「 | zjy | 左角引
」 | yjy | 右角引
『 | zsj | 左双角
』 | ysj | 右双角
〖 | zkf | 左空方
〗 | ykf | 右空方
【 | zsf | 左实方
】 | ysf | 右实方
± | zfh | 正负号
× | chk | 乘号
÷ | chk | 除号
∶ | bhk | 比号
∧ | ljc | 逻辑乘
∨ | ljj | 逻辑加
∑ | hhk | 和号
∏ | cjh | 乘积
∪ | bfh | 并符号
∩ | jfh | 交符号
∈ | sye | 属于
∷ | dyf | 定义符
√ | ghk | 根号
⊥ | czh | 垂直号
∥ | pxy | 平行于
∠ | jfo | 角符
⌒ | hfo | 弧符
⊙ | yfo | 圆符
∫ | jfb | 积分
∮ | hjf | 环积分
≡ | hdo | 恒等
≌ | qdo | 全等
≈ | ydo | 约等
∽ | jsl | 近似
∝ | zbe | 正比
≠ | bdo | 不等
≮ | bxy | 不小于
≯ | bdy | 不大于
≤ | xdy | 小等于
≥ | ddy | 大等于
∞ | wqd | 无穷大
∵ | ywu | 因为
∴ | syr | 所以
♂ | xfh | 雄符号
♀ | cfh | 雌符号
° | dfh | 度符号
′ | ffh | 分符号
″ | mfh | 秒符号
℃ | ssd | 摄氏度
＄ | myf | 美元符
¤ | thf | 通货符
￠ | mff | 美分符
￡ | ybf | 英磅符
‰ | qfb | 千分比
§ | jfh | 节符号
№ | bhf | 编号符
☆ | kxr | 空星
★ | sxr | 实星
○ | kyf | 空圆
● | syf | 实圆
◎ | sky | 双空圆
◇ | lxp | 菱形
◆ | slx | 实菱形
□ | fkt | 方块
■ | sfk | 实方块
△ | sjo | 三角
▲ | ssj | 实三角
※ | mhk | 米号
→ | yjt | 右箭头
← | zjt | 左箭头
↑ | sjt | 上箭头
↓ | xjt | 下箭头
〓 | qkf | 铅空符
① | qye | 圈一
② | qee | 圈二
③ | qse | 圈三
④ | qsf | 圈四
⑤ | qwe | 圈五
⑥ | qlg | 圈六
⑦ | qqa | 圈七
⑧ | qbo | 圈八
⑨ | qjo | 圈九
⑩ | qsa | 圈十
Ⅰ | lmy | 罗马一
Ⅱ | lme | 罗马二
Ⅲ | lms | 罗马三
Ⅳ | lms | 罗马四
Ⅴ | lmw | 罗马五
Ⅵ | lml | 罗马六
Ⅶ | lmq | 罗马七
Ⅷ | lmb | 罗马八
Ⅸ | lmj | 罗马九
Ⅹ | lms | 罗马十
Ⅺ | lsa | 罗十一
Ⅻ | lse | 罗十二
α | aef | 阿尔法
β | btt | 贝塔
γ | gmv | 伽马
δ | det | 德尔塔
ε | epx | 厄普西隆
ζ | jtt | 捷塔
η | ytt | 易塔
θ | xtt | 西塔
κ | kpj | 卡帕
λ | lmd | 兰姆达
ν | ypx | 宇普西隆
π | yzl | 圆周率
σ | xgm | 西格玛
ψ | pxe | 普西
ω | omg | 欧米伽
ā | pya | 拼音 a
á | pya | 拼音 a
ǎ | pya | 拼音 a
à | pya | 拼音 a
ē | pye | 拼音 e
é | pye | 拼音 e
ě | pye | 拼音 e
è | pye | 拼音 e
ī | pyi | 拼音 i
í | pyi | 拼音 i
ǐ | pyi | 拼音 i
ì | pyi | 拼音 i
ō | pyo | 拼音 o
ó | pyo | 拼音 o
ǒ | pyo | 拼音 o
ò | pyo | 拼音 o
ū | pyu | 拼音 u
ú | pyu | 拼音 u
ǔ | pyu | 拼音 u
ù | pyu | 拼音 u
ǖ | pyu | 拼音 u
ǘ | pyu | 拼音 u
ǚ | pyu | 拼音 u
ǜ | pyu | 拼音 u
ü | pyu | 拼音 u
ê | pye | 拼音 e
ㄅ | zyb | 注音 b
ㄆ | zyp | 注音 p
ㄇ | zym | 注音 m
ㄈ | zyf | 注音 f
ㄉ | zyd | 注音 d
ㄊ | zyt | 注音 t
ㄋ | zyn | 注音 n
ㄌ | zyl | 注音 l
ㄍ | zyg | 注音 g
ㄎ | zyk | 注音 k
ㄏ | zyh | 注音 h
ㄐ | zyj | 注音 j
ㄑ | zyq | 注音 q
ㄒ | zyx | 注音 x
ㄓ | zzh | 注 zh
ㄔ | zch | 注 ch
ㄕ | zsh | 注 sh
ㄖ | zyr | 注音 r
ㄗ | zyz | 注音 z
ㄘ | zyc | 注音 c
ㄙ | zys | 注音 s
ㄛ | zyo | 注音 o
ㄜ | zye | 注音 e
ㄝ | hee | 注音 e
ㄞ | zai | 注 ai
ㄟ | zei | 注 ei
ㄠ | zao | 注 ao
ㄡ | zou | 注 ou
ㄢ | zan | 注 an
ㄣ | zen | 注 en
ㄤ | ang | ang
ㄥ | eng | eng
ㄦ | zer | 注 er
ㄧ | zyi | 注音 i
ㄨ | zyu | 注音 u
ㄩ | zyu | 注音 u
a | ywa | 英文 a
b | ywb | 英文 b
c | ywc | 英文 c
d | ywd | 英文 d
e | ywe | 英文 e
f | ywf | 英文 f
g | ywg | 英文 g
h | ywh | 英文 j
i | ywi | 英文 i
j | ywj | 英文 j
k | ywk | 英文 k
l | ywl | 英文 l
m | ywm | 英文 m
n | ywn | 英文 n
o | ywo | 英文 o
p | ywp | 英文 p
q | ywq | 英文 q
r | ywr | 英文 r
s | yws | 英文 s
t | ywt | 英文 t
u | ywu | 英文 u
v | ywv | 英文 v
w | yww | 英文 w
x | ywx | 英文 x
y | ywy | 英文 y
z | ywz | 英文 z

符 号 | 编 码 | 参考名称
Γ Δ Θ Λ Ξ Π Σ Φ Ψ Ω | dxl | “大希腊”
α β γ δ ε ζ η θ ι κ λ μ ν ξ ο π ρ ? σ τ υ φ χ ψ ω | xxl | “小希腊”
Б Г Д Ж З И Й К Л П У Ф Ц Ч Щ Ъ Ы Ь Э Ю Я | dew | “大俄文”
а б в г д е ж з и й к л м н о п р с т у ф х ц ч ш щ ъ ы ь э ю я | xew | “小俄文”
ぁあぃいぅうぇえぉおかがきぎくぐけげこごさざしじすずせぜそぞただちぢっつづてでとどなにぬねのはばぱひびぴふぶぷへべぺほぼぽまみむめもゃやゅゆょよらりるれろゎわゐゑをん゛゜ゝゞァアィイゥウェエォオカガキギクグケゲコゴサザシジスズセゼソゾタダチヂッツヅテデトドナニヌネノハバパヒビピフブプヘベペホボポマミムメモャヤュユョヨラリルレロヮワヰヱヲンヴヵヶーヽヾ | rwu | “日文”

特别提示：
有些非汉字字符还可采用快捷键的方式输入，详见快捷键一览表。
中文标点符号可以用非字母键直接输入，详见中文标点符号输入。


 中文标点符号输入

名称 | 句号 |  | 问号 | 叹号 | 逗号 | 顿号 | 分号 | 冒号 | 双引号
符号 | 。 | ． | ？ | ！ | ， | 、 | ； | ： | “”
键位 | . | ` | ? | ! | , | \ | ; | : | “”

名称 | 单引号 | 圆括号 | 方括号 | 六角括号 | 方头括号 | 破折号
符号 | ‘' | （） | ［］ | 〔〕 | 【】 | ——
键位 | ‘' | () | [] | {} | [] | _

名称 | 省略号 | 连接号 |  |  |  | 间隔号 | 书名号
符号 | …… | — | —— | － | ～ | · | 《》 | 〈〉
键位 | ^ | - | _ | = | ~ | | | <> | <>

相关专题： 非汉字字符码


快捷键一览表

名称 | 输入符号 | 备注
/0 | ㈠㈡㈢㈣㈤㈥㈦㈧㈨㈩ | 全角符号
/1 | ⒈⒉⒊⒋⒌⒍⒎⒏⒐⒑⒒⒓⒔⒕⒖⒗⒘⒙⒚⒛ | 全角符号
/2 | ⑴⑵⑶⑷⑸⑹⑺⑻⑼⑽⑾⑿⒀⒁⒂⒃⒄⒅⒆⒇ | 全角符号
/3 | ①②③④⑤⑥⑦⑧⑨⑩ | 全角符号
/4 | ⅠⅡⅢⅣⅤⅥⅦⅧⅨⅩⅪⅫ | 全角符号
/5 | ⅰⅱⅲ ⅳⅴⅵⅶ ⅷ ⅸⅹ | 全角符号
/6 | １２３４５６７８９０ | 全角符号
/7 | ＡＢＣＤＥＦＧＨＩＪＫＬＭＮＯＰＱＲＳＴＵＶＷＸＹＺ | 全角符号
/8 | ａｂｃｄｅｆｇｈｉｊｋｌｍｎｏｐｑｒｓｔｕｖｗｘｙｚ | 全角符号
/9 | 十百千万亿拾佰仟萬億年月日时分秒元角块毛 | 全角符号
/+ 或 /= | 壹贰叁肆伍陆柒捌玖零→←↑↓◇◆☆★△▲ | 全角符号
/- | 一二三四五六七八九○＋－×÷＝≤≥＜＞※ | 全角符号
/* | 全角 / 半角切换 | 等同 Shift+Space
/. | 中文 / 英文切换 | 等同 Ctrl+.

    相关专题： 非汉字字符码


 万能键

    万能键"？"可用于代替任何（第1码除外）不能确定的码。举例：
鳖 -- BY?W （假如不能确定余部"敝"的首笔）
尴尬 -- G?G? 　（假如忘记了两个字的写法或者不知道部首）
刚愎自用 -- G?ZY（假如不知"愎"字的拼音首字母）


<用户自定义字/词>

 用户自定义字/词

    包括自定义通用词、自定义个性字/词。
    自定义词长度限定为2～17字。
    自定义编码限用26个字母；编码码长不能超出4码。

一. 自定义通用词
    自定义通用词不需要给出词条的编码，软件会自动根据音形码词码规则进行编码。
    词汇用字限定为6763字符集，不包括半角或全角非汉字字符。
    1.单条增加
    用鼠标右键点击三合一码输入法状态条，调出"自定义通用词"对话框：

    选择"单条增加"，在"待定义词条"框中输入词条，例如"无限风光在险峰"，用鼠标点击"开始"，出现"待定义词条：操作成功！……"的提示。退出后，即可用规则词码“wxff”输入"无限风光在险峰"。
    2.单条删除
    要删除用户已定义的词条，可选择"单条删除"，在"待删除词条"框中输入词条，按定义词条相同的方式操作即可。
    3.批量造词
    用户除可单条增加词条外，还可一次定义一批词条（自定义通用词条总数不多于5000条）。步骤如下：
    ①打开记事本等文本编辑器。
    ②输入待定义词条，要求每条词语占用1行。
    ③存盘。批量造词默认的存取路径和文件名：sy310\zdy.txt。
    ④在自定义通用词对话框中选择"批量定义"，在待定义文本的全路径名称框内键入待定义文件。
    ⑤点击"开始"，编辑框中显示已定义条数。
    提示：如果一条词语在自定义通用词库中已经定义，将自动剔除（写入sy310\err.txt以备查），不会重复定义。
    4.转换成文本
    用于对已经定义的自定义词进行查对和编辑修改，将已自定义好的全部词条逆转换为zdy0.txt文本文件，写入软件默认的文件夹中。
    5.浏览已定义文本
在转换成文本后，可以直接浏览已经定义的词汇，但不要在文本中直接增删（以免出错）。

二. 自定义个性词
    词汇用字限定为20902字符集和884个全角非汉字字符，但不包括半角字符。
    自定义个性词需要给出词条的编码，适用于以下3种情况：
    ①自定义词中有多音字，按自定义通用词定义后软件选择的音不正确，应作为自定义个性词，重新定义。
    ②自定义词中有全角非汉字字符，或者词汇用字超出6763字符集。
    ③希望使用自己喜欢的特殊编码（不受词码规则的约束）。例如，可将"中央电视台"的编码定义为"cctv"。
    自定义个性词步骤：
    ①用鼠标右键点击三合一码输入法状态条，调出"自定义个性字/词"对话框，选定"词汇增加/删除"。
    ②在待增加或删除词语框中输入词语，并给出编码和词频（词频取值00～99，必须为两位数，越小越常用，词频加到编码后面）。
    ③点击<开始>，框中显示"待增加/删除词语：操作成功！……"。
    举例：将"失效"定义为简码形式，取音形码规则编码"soxw"的前三码"sox"，词频取01(可取任意两位数)。（说明："失效"与"生效"重码并且不排首位，自定义简码后可用简码快速输入。）

    提示：超过三字的词语不要定义简码，即使定义成简码形式，软件也不会将它们作为简码处理。
    自定义个性词不应多于3000条。

三. 自定义个性字
    自定义个性字需要给出字的编码，适用于以下3种情况：
    ①可以将自己常用的字定义为较短码长（简码字）
    ②6763字集输入法可以由用户扩充定义输入20902大字集。例如，可根据自己的特殊需要，将超出6763字符集范围的一些字定义为音形码形式，扩大音形码的输入范围。
    ③可以给全角非字符号一个自己喜欢的编码，快捷输入。
    自定义个性字步骤：
    ①用鼠标右键点击三合一码输入法状态条，调出"自定义个性字/词"对话框，选定"单字增加/删除"。
    ②在待增加或待删除单字框中输入单个汉字或全角非字符号，并给出自定义编码。
    ③点击<开始>，框中显示"待增加/删除单字：操作成功！……"。
    举例：将"壹"定义为英文单词"one"。

    自定义个性字不应多于3000个。


 其它技巧

1. 自定义字/词
    可以按照自己的意愿自定义字码和词码，例如可以将"中央电视台"定义为"CCTV"。特别地，可以将常用的二字或三字词中重码而又不排首位者定义为简码形式，更有利于高速盲打。例如：
    ①自定义二字词二级简码（3码长）
    将常用而又不排首位的重码二字词自定义成二级（三码长）简码。例如，将重码组"生效、失效"（SOXW）中排第2位的"失效"定义成"SOX"（常规码的前3码），当输入3码后，"失效"将作为简码词排在首位，加打空格键后"失效"上屏。
    ②自定义三字词简码（3码长）
    所有三字词都没有设置简码，用户可根据需要自行设置简码。
特别提示：
    ①可以按音形码、形码、笔画码或者任意其它自己喜欢的方式自定义简码字、词（限用26个字母键），但是，简码不得重码，不能用同样的简码定义不同的字、词。（4码长的自定义码不受重码限制）。
    ②超过三字的词语不要定义简码，即使定义成简码形式，软件也不会将它们作为简码处理。
2. 用标点符号断码
    简码字、词或者未输足4码的其它首选字、词，须用空格键断码，但如果接下来的是标点符号，可以直接用标点断码，并继续输入后面的内容。
3. 部首查字
    有些疑难字，如果既不知道读音，也记不清写法了，只要知道部首即可查字：输入部首首笔和部首代码（即形码的前两码），可从重码字中寻找，由于同一部首的字排列在一起，查找比较方便。
4. 编码互查
    用拼音输入汉字后，自动显示字的 音形码 或 形码 ，可以掌握疑难字的部首和编码。用 笔画码 、 形码 和 音形码 输入汉字后，自动显示字的拼音，可以认读不认识的字。二者结合，既可克服几乎一切输入难题，又可通过输入汉字而学习汉字基础知识（指读音、部首、笔顺等）。例如，如果不知道"整"的部首，用拼音"ZHENG"输入后，在"整"字上屏的同时，在编码窗口自动显示"整"的音形码"ZWAZ"，根据第二码"W"，即可知道"整"的部首为"攵"。又如，如果不认识"刿"，用 形码 "IDIX"输入后，自动显示"刿"字拼音"GUI"。如果碰上既不知道部首又不知道读音的字，可先用笔画输入，将自动显示字的拼音，认识后再改用拼音输入，又会自动显示字的 音形码 或 形码 ，可掌握其部首和编码。如果不知道读音、也不知道写法怎么办呢？只要记得这个字组成的词或成语（该字不能是词的第一个字），就可以通过输入词码并用万能键代替的办法先输入词，然后再按上述方法认读这个字或学习其部首或编码。

相关主题： 用户自定义字/词
               字简码
               词简码


 各版本软件介绍

    1. 版本2004
    2004版应用GB2312-80字符集6763汉字；2004版词库，近9万条词语。2004版可高速盲打。

    2. 学生版(版本2007)
    学生版应用GB2312-80字符集6763汉字(略有扩充)；最新版2007版学生词库，约5.4万条词语，包括《现代汉语词典》、《中学生规范词典》和《现代汉语成语规范词典》等权威词典中的词条；笔画码采用"8画输入码+12画提示码"，可自动提示3500个常用字的规范笔顺。学生版适合于中小学生，可高速盲打。

    3. 通用版(版本2007)
    通用版应用GB13000.1字符集20902汉字(另加特殊汉字"○")；最新版2007版通用词库，约 11.5万条词语。词库主要由汉语通用词、词组、成语、俗语与谚语、常用接续与短语、诗词名句、专名（如地名、人名、朝代）等组成，词语覆盖面广，还包含最新流行词汇和网络常用词汇，并完全覆盖学生词库(与学生版“无缝”衔接)。通用版大词库，低重码，以词输入为主，轻松自如，熟练后高速盲打具有惊人的输入效率。通用版适合于社会各界、各行业人员（包括普通用户和专业打字员）。
    4. 组合版(学生版＋通用版,版本2007)
    组合版包含学生版和通用版两个版本，一体安装，切换使用。组合版适合于家庭成员中有中小学生的家庭使用，方便大人小孩都能用上合适的版本。也适合学生毕业后继续使用，而不必更换安装通用版。
    特别提示：一个操作系统只能安装一个版本的三合一码软件，如果一台电脑有多个操作系统，则每个操作系统可以各安装一个。


 官方网站

    访问三合一汉字输入法网站，可获取更多和最新的信息，并可免费下载最新版软件。

    网址： http://www.sanheyi.com


 联系方式

    感谢使用三合一汉字输入法！

    发明人刘春华真诚欢迎大家提出宝贵意见！

    联系地址：天津市北辰区引河里北道1号
              天津水泥工业设计研究院有限公司
    邮政编码：300400
    电　　话：13821535862
    电子邮箱： lch@sanheyi.com
    网　　址： http://www.sanheyi.com


 部首键位一览表

说明：
1.采用《汉字统一部首表（草案）》全部201个部首（"己"增加变形"已、巳"），变形部分保留圆括号( )。
2.另有 部首键位笔画排序检索表 ，可按笔画数检索查看部首的键位。
3.单笔部首横、竖、撇、点、折五类笔画，其中横画根据是否与其它笔画相交分别安排两个键位，并称为相交横和非交横。笔画的键位：相交横A，非交横E，竖I，撇O，点U，折V。详见 笔画及其键位 。
4.有11个常用的非成字部首采用指定键位，下面的顺口溜有可能帮助记忆：

    相关专题： 部首键位笔画排序检索表
               部首及其键位
               如何确定汉字部首


部首键位笔画排序检索表

    一. 采用《汉字统一部首表(草案)》201个部首("己"增加变形"已巳")，繁体和变形保留原括号，按原序号排列，繁体和变形单列时序号加方括号。与原形不在同一键位的变形不再附在原形后面，而在备注栏注明。
    二. 非成字多笔部首名称采用《新编实用汉语词典》(韩敬体等编，1990年北京，社会科学文献出版社出版)附录《汉字偏旁名称表》中的命名。

序号 | 部首 | 键位 | 备 注
一 画
1 | 一 | A | 相交横
 | 一 | E | 非交横
2 | 丨 | I | 竖
3 | 丿 | O | 撇
4 | 丶 | U | 点(捺)
5 | 乛(乙 [image] 乚) | V | 折
二 画
6 | 十 | S |
7 | 厂( [image] ) | C |
8 | 匚 | C | 形似
9 | 卜( [image] ) | B |
[22] | (刂) | D | 立刀
10 | 冂( [image] ) | T | 同字框
[12] | (亻) | L |
[7] | ( [image] ) | C | 原形“厂”
11 | 八(丷) | B |
12 | 人(入) | R | (亻) L
[12] | (入) | R |
[22] | ( [image] ) | D | 原形“刀”
13 | 勹 | B | 包字头
[10] | ( [image] ) | T | 原形“冂”
14 | 匕 | B |
15 | 儿 | E |
16 | 几( [image] ) | J |
17 | 亠 | G | 高字头
18 | 冫 | Q | 特殊安排
[11] | (丷) | B | 原形“八”
19 | 冖 | T | 秃宝盖
[166] | (讠) | A | 特殊安排
20 | 凵 | U | 形似
21 | 卩( [image] ) | E | 单耳旁
[175] | (阝左) | E | 双耳旁
[158] | (阝右) | E | 双耳旁
22 | 刀( [image] 刂) | D |
23 | 力 | L |
24 | 厶 | S | 私字
25 | 又 | Y |
26 | 廴 | J | 建之旁
[21] | ( [image] ) | E | 原形“卩”
三 画
27 | 干 | G |
28 | 工 | G |
29 | 土 | T | (士) S
[145] | (艹) | P | 特殊安排
30 | 廾 | N | 弄字底
31 | 大 | D |
32 | 尢(兀尣) | W | “兀”音
[32] | (兀) | W | Wù
[77] | (扌) | U | 特殊安排
33 | 寸 | C |
34 | 弋 | Y |
[54] | ( [image] ) | X | 原形“小”
35 | 口 | K |
36 | 囗 | F | 方框
37 | 巾 | J |
38 | 山 | S |
39 | 彳 | R | 双立人
40 | 彡 | P | 三撇
[64] | (犭) | Q | 反犬
41 | 夕 | X |
42 | 夂 | W | 折文
[185] | (饣) | S | 食字旁
43 | 丬(爿) | J | 将字旁
44 | 广 | G |
[95] | (忄) | N | 特殊安排
45 | 门(門) | M |
[97] | (氵) | I | 特殊安排
46 | 宀 | B | 宝盖
[160] | (辶) | V | 特殊安排
47 | (彐彑) | X | 彐 寻字头
48 | 尸 | S |
49 | 己(已巳) | J |
50 | 弓 | G |
51 | 屮( [image] ) | J | 形似“巾”
52 | 女 | N |
53 | 飞(飛) | F |
54 | 小( [image] ) | X |
55 | 子 | Z |
56 | 马(馬) | M |
[147] | (纟) | F | 特殊安排
[47] | (彑) | X | 原形“ [image] ”
57 | 幺 | Y |
58 | 巛 | G | 三拐
四 画
59 | 王 | W | (玉) Y
60 | 无(旡) | W |
61 | 韦(韋) | W |
[122] | (耂) | L | 老字头
62 | 木 | M |
63 | 支 | Z |
64 | 犬(犭) | Q |
65 | 歹(歺) | D |
66 | 车(車) | C |
67 | 戈 | G |
68 | 比 | B |
69 | 牙 | Y |
70 | 瓦 | W |
71 | 止 | Z |
72 | 攴(攵) | W | 攵 反文
73 | 日(曰 [image] ) | R |
[85] | ( [image] ) | Y | 原形“月”
74 | 贝(貝) | B |
75 | 见(見) | J |
76 | 牛 | N |
77 | 手( [image] ) | S | (扌) U
78 | 毛 | M |
79 | 气 | Q |
[72] | (攵) | W | 反文
80 | 长(長镸) | C |
81 | 片 | P |
82 | 斤 | J |
83 | 爪(爫) | Z |
84 | 父 | F |
[32] | (尣) | W | “兀”音
[83] | (爫) | Z | 爪字头
85 | 月( [image] ) | Y |
86 | 氏 | S |
87 | 欠 | Q |
88 | 风(風) | F |
89 | 殳 | S | Sｈū
90 | 文 | W |
91 | 方 | F |
92 | 火(灬) | H |
93 | 斗 | D |
[92] | (灬) | H | 原形“火”
94 | 户 | H |
[98] | (礻) | S | 示字旁
95 | 心 | X | (忄 [image] ) N
[143] | (肀) | Y | 原形“聿”
[43] | (爿) | J | 将字旁
[95] | (忄 [image] ) | N | 特殊安排
96 | 毋 | W | Wú (母) M
97 | 水(氺) | S | (氵) I
五 画
[59] | (玉) | Y |
98 | 示(礻) | S |
99 | 甘 | G |
100 | 石 | S |
101 | 龙(龍) | L |
[65] | (歺) | D | 原形“歹”
102 | 业 | Y |
103 | 目 | M |
104 | 田 | T |
105 | 罒 | S | 四字头
106 | 皿 | M |
[176] | (钅) | J | 金字旁
107 | 生 | S |
108 | 矢 | S |
109 | 禾 | H |
110 | 白 | B |
111 | 瓜 | G |
112 | 鸟(鳥) | N |
113 | 疒 | B | 病字头
114 | 立 | L |
115 | 穴 | X |
[140] | (衤) | Y | 衣字旁
[143] | ( [image] ) | Y | 原形“聿”
116 | 疋( [image] ) | P | Pǐ
117 | 皮 | P |
[97] | (氺) | S | 原形“水”
118 | 癶 | D | 登字头
119 | 矛 | M |
[96] | (母) | M |
六 画
120 | 耒 | L | Lěｉ
121 | 耳 | E |
122 | 老(耂) | L |
123 | 臣 | C |
124 | 覀(襾西) | X |
125 | 而 | E |
126 | 页(頁) | Y |
127 | 至 | Z |
128 | 虍(虎) | H |
129 | 虫 | C |
130 | 肉 | R |
131 | 缶 | F | Fǒｕ
132 | 舌 | S |
133 | 竹 | Z | ( [image] ) O
134 | 臼 | J | Jｉù
135 | 自 | Z |
136 | 血 | X |
137 | 舟 | Z |
138 | 色 | S |
139 | 齐(齊) | Q |
140 | 衣(衤) | Y |
141 | 羊( [image] [image] ) | Y |
142 | 米 | M |
143 | 聿(肀 [image] ) | Y | Yù
144 | 艮 | G | Gèｎ
145 | 艸(艹) | P | 特殊安排
146 | 羽 | Y |
147 | 糸(纟) | F | 特殊安排
七 画
148 | 麦(麥) | M |
149 | 走 | Z |
150 | 赤 | C |
[66] | (車) | C |
151 | 豆 | D |
152 | 酉 | Y | Yǒｕ
153 | 辰 | C |
154 | 豕 | S | Sｈǐ
[80] | (镸) | C | 原形“长”
155 | 卤(鹵) | L |
[74] | (貝) | B |
[75] | (見) | J |
156 | 里 | L |
157 | 足( [image] ) | Z |
158 | 邑 | Y | (阝右) E
159 | 身 | S |
160 | 辵(辶) | V | 特殊安排
161 | 釆 | F | 番字头
162 | 谷 | G |
163 | 豸 | Z | Zｈì
164 | 龟(龜) | G | gui
165 | 角 | J |
166 | 言 | Y | (讠) A
167 | 辛 | X |
八 画
168 | 青 | Q |
169 |  | C | 朝字边
170 | 雨 | Y |
[80] | (長) | C |
171 | 齿(齒) | C |
172 | 非 | F |
[128] | (虎) | H |
173 | 黾(黽) | M | Mǐｎ
174 | 隹 | Z | Zｈｕī
175 | 阜 | F | (阝左) E
176 | 金(钅) | J |
177 | 鱼(魚) | Y |
[45] | (門) | M |
178 | 隶 | L |
九 画
179 | 革 | G |
[126] | (頁) | Y |
180 | 面 | M |
181 | 韭 | J |
182 | 骨 | G |
183 | 香 | X |
184 | 鬼 | G |
185 | 食(饣) | S |
[88] | (風) | F |
186 | 音 | Y |
187 | 首 | S |
[61] | (韋) | W |
[53] | (飛) | F |
十 画
188 | 鬲 | G | ge
189 | 髟 | B | Bｉāo
[56] | (馬) | M |
190 | 鬥 | D |
191 | 高 | G |
十 一 画
192 | 黄 | H |
[148] | (麥) | M |
[155] | (鹵) | L |
[112] | (鳥) | N |
[177] | (魚) | Y |
193 | 麻 | M |
194 | 鹿 | L |
十 二 画
195 | 鼎 | D |
196 | 黑 | H |
197 | 黍 | S | shu
十 三 画
198 | 鼓 | G |
[173] | (黽) | M | Mǐｎ
199 | 鼠 | S |
十 四 画
200 | 鼻 | B |
[139] | (齊) | Q |
十 五 画
[171] | (齒) | C |
十 六 画
[101] | (龍) | L |
十 七 画
201 | 龠 | Y | yue
[164] | (龜) | G |

    相关专题：部首键位一览表
               部首及其键位
               如何确定汉字部首


如何确定汉字部首

    采用《学生规范字典》（李行健主编，中国大百科全书出版社，2001年7月第1版）和《现代汉语规范词典》（李行健主编，外语教学与研究出版社，语文出版社，2004年1月第1版）部首检字表的归部方法确定汉字部首。
    以下内容摘自上述两部辞书的部首检字表说明：

    一. 采用国家发布的《统一汉字部首表》立部。
二. 按照国家有关部门确定的"据形归部"的原则对所收的字归部。
三. 提取部首时，先对字形在部件相离处进行分解。凡笔画相交的，不可强行切分。如"寒"可分解为"宀、 [image] 、 [image] "，不可切分为" [image] 、 [image] "；"春"可分解为" [image] 、日"，不可切分为"夫、一、日"。
四. 部件分解后，分别不同情况按下述办法确定部首：
（1）上下结构或左右结构的字
a. 上下或左右两部分大体平衡的上下或左右结构的字，先分解为两部分。如："霖"分解为"雨"和"林"，"墨"分解为"黑"和"土"，"筐"分解为"⺮"和"匡"，"松""江"分解为"木、公"和"氵、工"。然后按照"先上后下、先左后右"的方法提取"雨"、"黑"、"⺮"、"木"、"氵"作部首。再如：
"思"字上边"田"下边"心"，都是部首，从上，归入"田"部；
"灵"字上边"彐"下边"火"，都是部首，从上，归入"彐"部；
"旧"字左边"丨"右边"日"，都是部首，从左，归入"丨"部；
"对"字左边"又"右边"寸"，都是部首，从左，归入"又"部。
这类字若第一次分解后上边或左边不是部首，则从下边或右边提取部首。如：
"券"字归入"刀"部； "契"字归入"大"部；
"剃"字归入"刂"部； "彩"字归入"彡"部。
b. 若上下结构的字，第一次分解后，上、下两部分都不是部首，则按先上后下的顺序进行第二次分解，提取该字的部首。如"舞"字第一次分解成" [image] ""舛"两部分，都不是部首，则进行第二次分解，先分解上边的" [image] "，得" [image] "" [image] "，两个都不是部首，再分解下边的"舛"，得"夕"" [image] "，其中"夕"是部首，据此把"舞"归人"夕"部。
c. 若左右结构的字，第一次分解后，左、右两部分都不是部首，则按先左后右的顺序进行第二次分解，提取该字的部首。如"疑"字经第一次分解成" [image] "" [image] "两部分，都不是部首，再进行第二次分解，先分解左边的" [image] "，得"匕""矢"，两个都是部首，根据先上后下的原则，把"疑"字归入"匕"部，而不归入"矢"部。
（2）上中下三部分构成的字，按上中下先后顺序提取部首。如"莹"分解为"艹、冖、玉"，取"艹"部。"暮"分解为"艹、 [image] 、日"，取"艹"部。左中右三部分构成的字，按左中右先后顺序提取部首。如"树"分解为"木、又、寸"，取"木"部。
（3）全包围结构的字，取外框部件为部首，如"国"取"囗"部。镶嵌式结构的字，取笔画相离并起镶嵌框架作用的部分为部首。如"幽"取"山"部，"爽"取"大"部。
（4）左上半包围结构的字，先取左上部分为部首。如"厄"取"厂"部，"虑"取"虍"部。若左上部分不是部首，则从右下被包围部分取部首。如"危"，"厃"不是部首，则取右下"⺋"为部首。若两部分都不是部首，则按先上后下、先外后内的原则提取部首。如"詹"，分解为"厃"和" [image] "，都不是部首，则取"⺈"为部首。
（5）左下半包围结构的字，先取左下部分为部首。如"迥"取"辶"部，"赵"取"走"部。如左下不是部首，则取被包围的部分为部首，如"题"取"页"部。
（6）右上半包围结构的字，如右上部件为独立部首，则取它作该字部首。如"戎""戒"取"戈"部。如果右上部分非独立部首，而被包围的左下部分为部首，则取左下为该字部首。如"栽"取"木"部，"裁"取"衣"部。如果右上和左下都不是独立部首，则按先上后下顺序对右上、左下部分再作分解，提取部首。如"戴"，右上" [image] "和左下"異"都不是部首，则先把" [image] "分解为"十、戈"，取"十"为部首。
（7）在同一位置可提取单笔画部首，也可提取多笔画部首的字，归入多笔画部首，而不归入单笔画部首。如"亲"可归入"亠"部，也可归入"立"部，取多笔画的"立"，而不取"亠"为部首。
（8）笔画相接或相交，不便分解提取部首的字，按起笔笔形提取部首，如：
"才""枣""事"归入"一"部； "电""甲""果"归入"丨"部；
"乌""我""垂"归入"丿"部； "丑""书""承"归入"乛"部。

附：三合一码中与《学生规范字典》归部不一致的字及其原因

序号 | 汉字 | 三合一归部 | 《学》归部
1 | 秉 | 丿 | 禾
2 | 斥 | 丿 | 斤
3 | 冉 | 丨 | 冂
4 | 内 | 丨 | 冂
5 | 巴 | 乛 | 巳
6 | 乃 | 乛 | 丿
7 | 善 | 口 | 羊
8 | 纛 | 母 | 毋
9 | 贯 | 贝 | 毋

    改变归部的原因：
    序号1：①根据部首检字表说明第"四（8）"条规定，应按起笔笔形提取部首；②《学生规范字典》中类似结构字"夷"取"一"而不取"大"为部首，宜统一。
    序号2：①同"序号1①"；②《学生规范字典》中类似结构字"本"取"一"而不取"木"为部首，宜统一。
    序号3：①同"序号1①"；②《学生规范字典》中类似结构字"果"取"丨"而不取"木"为部首，宜统一。
    序号4、5：同"序号1①"。
    序号6：①同"序号1①"；② "乃"起笔为"乛"，不是"丿"。
    序号7：根据部首检字表说明："三. 提取部首时，先对字形在部件相离处进行分解。"
    序号8：①"母"为"毋"的变形，形和音都差别明显，宜单列；②《现代汉语规范词典》也将"纛"归入"母"部。
    序号9："毋"的变形只有"母"一种，没有" [image] "。

    相关专题：部首及其键位
              部首键位一览表
              部首键位笔画排序检索表


 笔顺规则及疑难字笔顺
一. 汉字笔顺规则（摘自《现代汉语规范词典》附录）

（一）基本规则
1. 从左到右 礼：礻 礼 / 谢：讠 [image] 谢
2. 从上到下 三：  [image] 三 / 竟：立 音 竟
3. 先横后竖 十：一 十 / 王：  [image] 王
4. 先撇后捺 八：丿 八 / 文：亠 [image] 文
5. 先外后里 同：冂 同 / 司： 司
6. 先外后里再封口 国：  [image] 国 / 回：  [image] 回

（二）补充规则
1. 当中间部分长或宽时，先写中间后写两边。如：
水：亅 [image] 水 / 办：力 办
2. 正上、左上的点必须先写。如：
立：丶 亠 立 / 头：丶 [image] 头
3. 右上、里边的点必须后写。如：
戈：一 [image] [image] 戈 / 瓦：一 [image] [image] 瓦
4. "走之儿""建之旁"最后写。如：
迟：尺 迟 / 延： 延
5. "匠字框"的字，先写上边一横，然后写里边，最后写竖折。如：
匾：一 [image] 匾
6. "凶字框"的字，先里后外。如：
函：了 [image] 函

二. 易弄错的笔画和笔顺

及九匕：撇、折 乃力刀万方：末笔是撇
敝：首笔是点 舟母：末三笔是点横点
忄：点、点、竖 北：竖、横
门：点、竖 那：折、横
五：横、竖 丑：折、竖
长：撇、横 兆：撇、点
非：竖、横 髟：横、竖
戈龙：末笔是点

此外，"车、牛"末笔是竖，但作左偏旁是末笔变为提；"月、用"作下偏旁时，首笔变为竖，如"肖、肓、育、肩、肾、肯、背、胃、胄、散"和"甬、涌、俑、蛹、踊"等。

 三. 部分疑难汉字笔顺（摘自《GB13000.1字符集汉字笔顺规范》）

汉字 笔画数 笔顺
馬 10
鳥 11
門 8
鬥 10
龜 17
黽 13
淵 12
飛 9

相关专题：笔画及其键位
 笔画码（通用版）
笔画码（学生版）


统一汉字编码路线图

（刘春华）

1. 统一汉字编码的战略目标

① 统一的汉字编码要同时适用于汉字的键盘输入和排序检索，并通用于所有汉字，适合处理全汉字集。

② 汉字编码用于键盘输入时，要与识字同步并终身适用，要同时满足各行各业的使用要求，全社会通用。

2. 统一汉字编码的自然之路

进入基础教育课程，是汉字编码及输入法最自然的统一之路。只要做到“教学用”与“社会用”无缝衔接，学生群体走出校门走入社会后，自然会“统一”使用同一种汉字编码及输入法。汉字编码属于语文课内容，应进入小学语文课程；输入法软件的使用属于信息技术课内容，应进入小学信息技术课程。

3. 汉字编码进入小学语文课程的方式

汉字编码进入小学语文课程的方式，宜以不改变现行识字教学模式为前提，使汉字编码知识“潜入”语文课程，与原有课程内容高度融合，即在不干扰现行小学语文教学方法和教学进度的条件下做到与识字同步，让学生在学习拼音识字、写字和偏旁部首等知识的同时也循序渐进地、同步地学会汉字编码。与汉字编码在语文课程中采用的非集中教学方式相对照，小学信息技术课程适合专列一项汉字输入法内容，集中教学输入法软件的使用方法。

汉字编码进入语文课程的教学进度，要与识字及写字的教学进度相一致，并与信息技术课程教学输入法软件操作合理衔接。按照《全日制义务教育语文课程标准（实验稿）》，在 1 ～ 2 年级阶段，要求学生学会汉语拼音，掌握汉字的基本笔画和常用的偏旁部首，能按笔顺规则用硬笔写字，能用音序和部首检字法查字典，认识常用汉字 1600 ～ 1800 个，其中 800 ～ 1000 个会写，等等，作为与识字同步的汉字编码知识也应安排在这一阶段基本学会，并可应用于汉字输入和字典查字（替代部首检字法）。

如果采用以五笔字型为代表的传统的拆分部件式的形码方案，即使部件拆分完全符合文字学规范，即使完全不考虑方案本身的学习难度，若要进入小学语文课程，都不得不要对现行 以分析偏旁结构为主的小学 识字教学模式进行“伤筋动骨”的改造，实际是要创立一种新的教学模式。这样做有两个难点，一是要创立一种新模式并能够取代现行模式在全国小学语文教学中普遍推广，即使没有汉字编码及输入法的“羁绊”，要做到这一点也不是一般的难，二是这种新的识字教学模式还要受到汉字编码和输入法本身性能要求的制约，换句话说，首先要让汉字编码及输入法方案本身能够满足相应的性能要求，然后由该汉字编码及输入法方案“衍生”创立的新的识字教学模式还要优于现行小学识字教学模式。显然，这是一种本末倒置的做法，是不可能实现的。适宜的做法不能是削足适履，为迁就汉字编码和输入法而试图创立一种新的识字教学模式，应该反过来以现行小学语文教学模式为基点，创造一种既能与现行识字教学模式高度融合，又能满足相应性能要求的新的汉字编码及输入法方案。

4. 汉字编码进入小学语文课程的条件

① 汉字编码符合规范化要求

编码要完全符合语言文字规范；编码应没有歧义，即每个汉字的符合规则的编码具有唯一性；编码应用要有利于促进语言文字应用规范化，例如，汉字输入软件要采用规范词库，要有“提示”或“纠错”功能，能够引导使用者正确读音和书写，正确用字和用词，等等。

② 汉字编码不增加语文基础教育负担

汉字编码进入小学语文课程后不能增加学习负担。要做到这一点，汉字编码就要与小学语文课程教学的汉字基础知识高度相关。这里所说的汉字基础知识主要指“识字与写字”方面的知识，包括字的读音（汉语拼音），笔画笔顺和偏旁部首等。如果将现行语文课程中要求学生掌握的汉字基础知识称作语文课程的“存量”知识，汉字编码内容中超出这个范围的称作“增量”知识，汉字编码应该以“存量”知识的组合应用为主，“存量”知识的组合应用需要一定的规则，这些规则就属于“增量”知识。规则越简单，“增量”就越小。如果新进入语文课程的汉字编码知识与“存量”知识之间高度相关，学习和使用汉字编码对学习这些“存量”知识的正面影响可抵消学习“增量”知识的负担，就可做到不增加甚至减轻语文基础教育负担。

③ 汉字编码与识字同步并终身适用

拼音文字从初学起即可同步输入，汉字编码用于汉字输入时要与识字同步，还要与语文教学进程动态适应，“无级”提速，并终身适用。如果学生走出校门后，还要另学一种输入法，这是不可接受的。“教学用”与“社会用”要无缝衔接。“教学用”与“社会用”的区别应仅仅局限于这样一些方面：“教学用”输入法的应用字集和词集适合教学，并更多地为学生用户提示有关的汉字基础知识（如读音、笔顺、部首等）。就好像学生字典的收字范围与语文教学相适应，字量少，解释提示多，但小学生们学会查学生字典后同样会查通用字典。对个体用户而言，汉字编码及输入法要与识字同步并终身适用；对全体用户而言，汉字编码及输入法要全社会通用。汉字输入法要做到终身适用、全社会通用，除其他要求外，还要满足两项极端要求，一是满足职业录入员对输入速度的要求，二是适合处理大汉字集直至全汉字集（不包括古文字）。

需要指出的是，上述汉字编码进入小学语文课程的条件与统一汉字编码的战略目标是一致的。

5. 编码设计的总体方案

编码设计要以满足进入小学语文课程的条件为目标要求，总体方案设计要重点解决既与识字同步又终身适用、全社会通用的问题。

作者在 1997 年第一次提出 [1][2] ，汉字编码的理想模式应是一种建立在汉字基础知识之上而与语文基础教学规律相一致的组合式编码系统，即应设法将音码、形码和音形结合码等不同类型的多种编码组合成一个统一体，依靠码元、键元及编码方式的科学组合，在汉字键盘输入时实现各种编码的不切换混用，使不同阶层的使用者以及同一使用者在其接受语文基础教育的不同阶段均能用上与其语文知识水平相适应的编码，而所有种类的编码又都同属于一个统一的编码系统，各种编码间的衔接具有与语文基础教育同步的、循序渐进的基本特征。十年后，作者于 2007 年进一步提出 [3] ，应该将汉字编码和输入法纳入到汉字教学和应用的大系统中统筹考虑。一方面，汉字编码和输入法要满足汉字教学的需要，要遵守国家语文规范，与语文基础教学内容和规律相适应，要与识字同步，小学生们可随机地、综合地利用在常规语文课程中学会的拼音、笔画、部首及词汇知识输入汉字。另一方面，汉字编码及输入法要满足汉字应用的需要，要与汉字排检方法统一，要通用于全部汉字。即汉字编码及输入法的战略目标为：统一适用于键盘输入和汉字排检的汉字编码；建立在汉字基础知识之上、应用拼音、笔画和部首，能够“无级变速”式的汉字输入法；适合处理全汉字集、通用于全社会的汉字输入法。无论音码，形码，还是音形结合码等，都不能以单一方式同时满足上述全部要求，须应用系统工程的方法，统筹设计一种多方式、不冲突、免切换汉字输入系统。

从与识字同步方面考虑，学习拼音识字时，需要音码（全拼），学习写字时，又需要笔画码。从终身适用、全社会通用方面考虑，应用字集不受限制，要适合处理大汉字集直至全汉字集，不能缺少形码。由于音码单字重码多，笔画码效率低，形码既要覆盖全部汉字又要简单易学，重码也不可能少，因此，从满足职业录入员的输入速度要求方面考虑，有必要增加一种音形码，以实现在通用字范围的高速盲打。此外，从简化系统和提高编码空间使用效率等方面考虑，宜选择一种编码作为主要方式，用于单字和词语输入，以词输入为主，其余为辅助方式，只用于单字输入，并使主要方式比辅助方式以及主要方式中的词码比字码获得更大的键元编码空间。按照上述思路，可提出编码系统的总体方案如下：

音形码：应用字集为 7000 通用字，用于单字和词语输入，词输入为主。

音 码：全拼方式，应用字集为 20902 字（ GB13000.1 字符集） ，教学用可调整为 7000 通用字，只用于单字输入。

笔画码：纯笔画方式，应用字集根据需要确定，教学用可设为 3500 个常用字加上形码编码疑难字，只用于单字输入。

形 码：设计目标字集为全部汉字（不包括古文字），实际应用字集根据需要确定，只用于单字输入。形码还设计用作字典查字法。

上述系统要实现不切换混合使用，要求各种码的键元编码空间互不相交，字码空间与词码空间也互不相交，或者尽量减小它们之间的交集，以不影响实际使用为限，特别是不能干扰音形码在通用字范围的高速盲打，这是编码系统总体方案成败的关键。这需要在码元、码元键位和取码规则等方面统筹兼顾，综合设计。

6. 编码设计的技术要点

① 键元

《 GB/T 19246 — 2003 信息技术 通用键盘汉字输入通用要求》规定“应采用” 26 个字母键。键元限用 26 个字母键有利于与通用键盘兼容。

② 码元

系统中含有拼音方式，码元中应包括《汉语拼音方案》字母表中所列 26 个字母。其中的“ v ”在拼音输入方式中用于在适合时替代表示通用键盘上缺少的“ü”。

系统中还有笔画码，码元中也须包括笔画。汉字笔画细分种类不少，但汉字部首中仅含有 5 种单笔部首，为简便和统一起见，笔画码元宜采用横、竖、撇、点（捺）、折 5 种基本笔画。

形码码元普遍采用汉字部件。部件应用的主要难点包括：基础部件数量多，又可组合使用，记忆量大；汉字结构复杂，易导致拆分歧义；有很多无音部件无法用简单易记的方式安排键位；等等。传统汉字学常用“偏旁”和“部首”两个术语，“部件”则是现代才开始启用的新术语，并且还与传统的“偏旁”概念处理不好关系，造成混乱。在《 GF 3001 — 1997 信息处理用 GB13000.1 字符集汉字部件规范》发布实施十余年后，又发布了《 GF 0014 — 2009 现代常用字部件及部件名称规范》，前者“对中文信息处理，特别是对汉字键盘输入方法，具有规范作用”，“主要用于中文信息处理领域的设计、管理、科研、教学和出版等方面，也可供汉字教学参考”，后者“适用于汉字教学、辞书编篡等方面的汉字部件分析与解说，也可供汉字信息处理等参考”，两个部件规范分别针对不同的用途，说明部件用于汉字编码和用于汉字教学二者的要求是不一致的。有资料显示，在一种六年制小学语文教材中，一年级用字 667 个，涉及非成字基础部件 228 个，从这两个数字之比来看，部件无论用于语文教学还是用于汉字编码，“起步”的难度都比较大。根据以上分析，采用一般的汉字部件作为形码码元并不理想。

小学识字教育当前仍以分析偏旁结构为主，与小学语文教学的汉字基础知识具有最高关联度的形码码元选项，应该是偏旁和部首。但目前学术界对偏旁还没有一个统一的认识，偏旁数量也过多，不适合用于编码。与部件和偏旁相比，部首的规范程度最高（已基本统一），数量适中，并且长期用于流行的字典查字法，用作码元还有利于输入法与查字法的统一。因此，部首适合作为形码码元。由于部首不能覆盖汉字的所有结构部件，形码码元中还需要包括 5 种基本笔画，用于对非部首结构取码。

综上所述，码元宜包括： 26 个拼音字母、 5 种基本笔画、《 GF 0011 — 2009 汉字部首表》 201 部首（包括附形部首）。拼音字母、笔画和部首均属于语文基础教学内容，属于小学语文课程的“存量”知识，将它们用作码元，既可完全符合语文规范，与识字教育一致，不增加学习负担，又有利于在编码规则不作修改的前提下通用于全汉字集，因为汉字笔画和部首本身就通用于全部汉字。

③ 码元的键位

码元的键位与编码的易学性关系极大，安排码元键位也须尽量应用小学语文课程的“存量”知识。

拼音字母的键位应执行《 GF 3006 — 2001 汉语拼音方案的通用键盘表示规范》。

笔画种类少，记忆量也小，安排键位时重点不在易学性方面。对于多方式、不切换输入系统，安排笔画键位要考虑的重点是：与其他码元的键位及取码规则相配合，实现各种码之间以及字码与词码之间的键元编码空间互不相交，或者尽量减小它们之间的交集。作者采用的方法是将 5 种基本笔画对应 AEIOUV 等 6 个键（其中横画根据是否与其他笔画相交分别对应 A 和 E 两个键），它们或者不用于拼音首字母，或者虽用于拼音首字母但涉及字数少。

部首键位是影响易学性的关键。一般来说，码元“音托”最为简单，“形托”次之。因此，部首键位应以“音托”为主。部首包括成字部首和非字部首。其中成字部首应一律“音托”，例如：日 R 、月 Y ，等等。非字部首宜采用部首名称“音托”，例如：宀 B 、刂 D ，等等。

少数部首的键位可能极大地影响编码的重码率，有必要对它们采用指定键位。指定键位属于无理编码，必然会增加学习和记忆难度，但这是提高效率的必要成本。关键是要找到一个合适的平衡点，使难度和效率二者都在可普遍接受范围。首先，指定键位者只限于非字部首，不能用于成字部首。其次，指定键位者应具有较高的动态和静态组字频度。动态组字频度高，频繁使用容易记住；静态组字频度高，才可能对重码率产生大的影响。

成字部首一律“音托”，既是方便记忆的需要，也是从整个编码系统统筹考虑的结果。因为系统中含有多种输入方式，如果成字部首中有非“音托”键位者，当它作为独立汉字用拼音或音形码输入时的第一个输入键与它用作部首时的输入键就会不一样，容易造成混乱。部首“音托”，也是利用语文课程的“存量”知识，几乎不需要另外学习就能记住（其中的不常者除外）。

④ 取码规则

重点讨论形码和音形码的取码规则。

形码除用于汉字输入外，还要用于字典查字。传统的部首查字法也可看作是一种“形码”。部首查字法涉及部首和笔画数，形码涉及部首和笔画，可根据部首查字法的基本思路来设计形码规则。用部首查字法查字，先用部首的笔画数在部首目录中查到该部首的页码并在检字表的相应页中找到该部首，然后再用余部（不包括部首的部分）的笔画数在检字表中该部首项下找到目标字，基本思路为：部首笔画数→部首→余部笔画数→目标字。仿此，但用部首的首笔代替部首的笔画数，用余部的首笔和末笔代替余部的笔画数，得出形码的初步规则：“部首首笔、部首、余部首笔、余部末笔”。由于大多数汉字的余部末笔所在部位也是一种部首，如“始”的余部“台”的末笔部位是“口”，取该部首替代末笔可以提高效率（更直观且更少重码），形码规则可调整为：“部首首笔、部首、余部首笔、余部末位码”，其中，若余部的末笔部位也是一种部首，余部末位码取该部首，否则取末笔。形码举例：始 VNVK （其中 V 是折笔的键符， N 和 K 分别是“女”和“口”的拼音首字母）。

将形码的第一码“部首首笔”改为汉字的“拼音首字母”就变成音形码，即音形码字码规则为：“拼音首字母、部首、余部首笔、余部末位码”。音形码举例：始 SNVK 。词码以字码为基础：二字词取每个字的前二码，三字词取每个字的第一码和末字第二码，四字及以上词语取前三末一字的第一码。词语码举例：科学 KHXZ （科、禾、学、子），科学家 KXJB （科、学、家、宀），科学技术是第一生产力 KXJL （科、学、技、力），等等。

7. 编码方案的性能分析

在前述总体方案和技术要点的基础上作进一步的细节设计，即形成三合一汉字编码及输入法方案。该方案采用《 GF 0011 — 2009 汉字部首表》 201 部首（包括附形部首），除所有成字部首和大部分非字部首“音托”键位外，非字部首中有 3 个“形托”键位， 11 个指定键位。另外，非汉字字符编码类似于音形码，但取 3 位码长，与 4 位码长的音形码互不冲突，例如：℃ ssd （摄、氏、度），对比音形码词码：摄氏度 ssdg （摄、氏、度、广）。限于篇幅，其他细节不赘述。

下面对照汉字编码进入小学语文课程的条件以及统一汉字编码的战略目标，具体分析三合一汉字编码及输入法方案的技术性能。

笔画键元和取码规则二者配合利用 AEIOUV 等 6 个键，使各种输入方式之间以及字码与词码之间发生冲突的几率很小。简单分析其原理：音形码第一码是拼音首字母，形码第一码是部首首笔，二者只在 AEO 三个字母项下存在交集，但涉及字数很少，故音形码与形码发生冲突的几率很小；在音形码中，字码第三码是笔画而词码第三码是拼音首字母，基于同样道理，字码与词码冲突的几率也很小。笔画码和音码加入后发生冲突的几率同样很小，限于篇幅，不再详细分析。由于拼音首字母的键元数量数倍于部首首笔，因此音形码的键元编码空间也数倍于形码空间，音形码中的词码空间同样数倍于字码空间，键元编码空间分配符合“音形码为主、词输入为主”的目标要求。

所有码元均属于语文课程的“存量”知识，拼音全拼方式、成字部首“音托”和非字部首按名称“音托”键位所依据的字音、笔画码所依据的笔顺规范等也都属于“存量”知识。“增量”知识包括： 5 种基本笔画的键位、少量必要的非字部首的指定键位、形码和音形码的取码规则等。其中形码的取码规则脱胎于部首查字法，而音形码字码与形码只在第一码上有区别，可同时学会。音形码和形码都不需要拆分汉字（确定部首时若涉及汉字切分则属于部首规范本身的内容）。音形码以词输入为主，词输入以拼音首字母为主，部首为辅。由于部首的取部位置一般都在显著之处，因此绝大多数汉字的部首一目了然，取码方便快捷。

再结合语文课程标准要求以及 1 ～ 2 年级教学进度来考查编码系统的学习负担。从拼音识字起，单个汉字的全拼方式与课程一致。写字教学时，新增学习量仅限于 5 种基本笔画的键位。教学部首时，需要同时教学部首的键位，其中成字部首一律“音托”和非字部首按名称“音托”的键位可近似地认为不增加学习负担，只有少量非字部首的指定键位属于新增学习量。教学形码和音形码的取码规则可以安排在二年级上学期原来教学部首查字法时进行，并且以形码取代部首查字法用于字典查字（不再教学原部首查字法）。

音形码在 GB2312-80 字符集 3755 一级字范围的静态重码率为 6.36% ，若计入三级字简码（取常规 4 码的前 3 码），这个数字降为 1.8% 。已实现版本的形码字集 20902 字（音形码字集为其中 7000 通用字）、词集约 11.5 万条词语，其重码率 / 键选率水平仍可满足职业录入员的盲打要求。

基于上述分析，这样一种编码系统应可满足与识字同步、“无级提速”、终身适用的要求：小学生初学汉语拼音，可用拼音输入单个汉字；学习写字，又可用笔画输入单字；学习部首后，可随机改用效率更高的音形码输入单字和词语，还可用形码输入不认识的字等；由于各种输入方式的使用是随机性的，不需要切换操作，这是一个完全动态适应、无缝衔接的过程；音形码字集为通用字，形码字集根据需要可覆盖全部汉字，形码字集扩大不影响音形码在通用字范围的单字和词语的快速输入，词集扩大不影响单字输入，因此，学生走出校门后无论从事何种职业，均可继续使用同一输入法；形码用作字典查字法也终身适用。

按照本文讨论的方案，汉字编码进入小学语文课程并不以“使用电脑”为必要条件，而是以不改变现行识字教学模式为前提，原有语文教材内容可只作小的改动（主要包括增加笔画和部首的键位、用形码替代部首查字法等），课堂教学方式和进度也可基本保持不变，即便是不具备电脑的学校也同样适合教学，因为脱胎于部首查字法的形码可首先作为字典查字法教给学生，使之成为终身适用的语文基础知识，即使当时没有条件使用电脑，也能在以后任何有机会使用电脑时很轻松地学会使用相应的输入法。汉字编码以这种方式进入语文课程，有利于在包括教育设施不足的经济落后地区在内的全国范围的国民义务教育中普遍地、同步地实施，而不是只能局限于在发达地区的小学校中实施。

8. 汉字输入法的功能空间

三合一汉字输入法软件设有一些简单功能：用拼音输入汉字后，在编码窗口自动提示音形码或形码，方便掌握疑难字的部首和编码；用非拼音方式输入后，自动提示拼音，可随时认读不认识的字；学生版笔画码自动提示 3500 个常用字的规范笔顺；自定义词加标志，以提醒使用者注意自定义词中是否有错别字；等等。这些都属于很初级的辅助学习功能。实际上，在汉字输入法的“周边”，存在巨大的功能空间。限于篇幅，本文对此不作详细论述，仅抄录一段作者以前发表过的文章的一段话，表达一种基本概念：

借助日益先进的电脑多媒体技术，输入法软件有可能发展成为一种多功能的汉字学习和语文实用工具，甚至成为一种文化学习工具，也可作为外国人学习汉语汉字和中国文化的一种辅助工具。为实现这个目标，建议建立国家级、系统化、权威性的相关资源系统。不算字符集，输入法的广义的资源系统可包括词语资源库和文化资源库两个层级。词语资源库直接用于汉字输入和辅助汉语汉字学习。应建立国家规范的、分级的、适合输入法用途的学生词库、通用词库和各种专业词库，以利于提高汉字输入的效率和规范化水平。文化资源库则可作为词语资源库的延伸，一种百科全书式的知识库，方便输入法用户在输入汉字过程中随时查询、参考和学习。

9. 统一汉字编码路线图

以上面的讨论为基础，试着勾画出统一汉字编码路线图。

① 确立统一汉字编码的战略目标

主要从满足汉字教学和汉字应用两个方面的实际需要来确立统一汉字编码的战略目标。要满足汉字教学的需要，最低要求是应用汉字编码不干扰正常的汉字教学，最高境界是汉字编码可用于辅助汉字教学，减轻识字负担。要满足汉字应用的需要，其中包括汉字键盘输入与汉字排序检索方法要统一，要适合处理全汉字集、通用于全部汉字，统一的输入法方案要能同时满足各行各业的使用要求。

② 确定统一汉字编码的操作途径

进入国民基础教育课程是汉字编码和输入法最自然的统一之路，前提是“教学用”版本与“社会用”版本无缝衔接。

③ 设立汉字编码进入基础教育课程的条件

重点是设立汉字编码进入小学语文课程的条件，这个条件在大的方面与统一汉字编码的战略目标一致。

④ 设计汉字编码及相应的输入法方案

这个方案应具备两个基本特征，一是以拼音字母、基本笔画和统一部首为码元的汉字编码系统，满足与语文基础教育一致、可辅助汉字教学的要求；二是多方式、不冲突、免切换的汉字输入系统，满足与识字同步、终身适用、全社会通用的要求。

⑤ 教材准备

将汉字编码知识编入语文教科书；输入法软件使用方法编入小学信息技术教科书；编纂以汉字编码为查字法的学生字典。

⑥ 试点实验

选择若干小学校作为试点校，进行实验教学，总结经验，完善提高，直至获得满意的结果。

⑦ 制定国家标准

制定统一汉字编码和输入法的国家标准，并将汉字编码教学内容编入小学语文课程标准，输入法教学内容编入小学信息技术课程标准。后续工作还包括建立适合输入法软件应用的国家级的词语资源库和文化资源库等。

⑧ 全国小学校普遍实施

⑨ 最终实现统一

“教学用”版本与“社会用”版本无缝衔接，学生毕业后将使用统一的汉字编码和输入法。此前已经完成语文基础教育的社会各行各业人员是否也愿意学习使用统一方案，可悉听尊便，没必要限制其他方案的应用。统一方案与其他方案将有一段时间的“共存期”，但最终会自然实现统一。

10. 没有结束的结束语

汉字编码和输入法不统一所造成的各种资源浪费和社会隐性成本无法计算，统一汉字编码和输入法的社会效益和经济效益无论作这样高的估计都不为过。遗憾的是，经过了上世纪末期“万码奔腾”的喧嚣后，汉字编码和输入法的话题已很少有人提起。近年唯一的一次“热闹”是两个知名的网络公司因拼音输入法引起的一场争端，其中最具讽刺意味的是，两个输入法中存在的大量相同的错误词条竟成了一方指责另一方侵权的重要证据，据说二者相同的错误词条超过 10000 条！不同的错误词条还有多少呢？不得而知。“看热闹”的人群中，很少有人关心拼音输入法的词语错误。普通百姓忙于生计而漠视文字游戏无可指责，但那么多的语言文字专家和语文教育专家也“路过”而已，则实在令人悲哀和绝望！

汉字编码至今难以统一，原因何在？或者是缺少宏观战略思想的指导，不知路在何方；或者是战略有误，打算让音码单打独斗一统天下。对此，国家有关主管部门难辞其咎，有话语权的专家学者们也脱不了干系。国家有关部门曾在未经充分论证的情况下，轻率地向全国中小学生推荐过一种编码输入法，结果引起广泛非议，最后无疾而终。“一朝被蛇咬，十年怕井绳”，政府主管部门从此走向了另一个极端，对编码输入法问题唯恐避之不及，基本上不作为了。从我国汉字编码及输入法发展历史来看，软件界功勋卓著，语文界少有作为。从现状来看，中文信息领域 的精英们埋头于自然语言理解、机器翻译等高深、前沿课题，没功夫也不屑于关心汉字编码和输入法问题；学富五车的语言文字专家、语文教育专家们也一如既往地对汉字编码和输入法问题集体失语，很大度地放手让网络公司和软件开发商们八仙过海各显其能。

在相当一段时期，有相当一批专家，推崇通过市场竞争来优胜劣汰汉字输入法，作者曾对此极为反感，并曾在光明日报发表的一篇文章中对此提出非议。但现在反过来想一想，政府部门指望不上，专家学者也指望不上，还能指望谁呢？只有企业家了。想象中的康庄大道原来一直就不曾开通，也只有市场竞争一条险路了。幸好，在各种行业中，某个企业标准由于其领先性而上升为国家标准甚至国际标准的不乏先例。企业要以盈利为目的，否则无法生存。做汉字编码和输入法有市场吗？全国在校中小学生人数大约有 2 亿，每年新入学小学生还有一千多万，如果你的产品能够辅助汉字教学，就算只生产小霸王学习机一类的产品，其潜在的市场想小也难。如果你的产品做得足够好，甚至能够作为一种文化学习的辅助工具，有软件产品，有用汉字编码作为查字法的学生字典，再放眼“汉语热”逐渐升温的国际市场，等等等等，市场之大，无可怀疑。现在，就让我们以极大的热情，寄希望于企业家的远见卓识吧！中国的企业家们，该你们见义勇为，挺身而出了——以市场开路，推动并最终完成汉字编码和输入法的统一大业，让承载五千年中华文明的古老汉字，以青春焕发的崭新形象，屹立于世界文字之林，让源远流长的方块汉字，尽情闪烁标准化、信息化之光，与日月同辉！

参考文献：

[1] 刘春华 . 试论汉字编码的宏观要求及理想模式 [J]. 科技导报， 1997 ， (7).

[2] 刘春华 . 组合式汉字编码系统研究 [J]. 科技导报， 1998 ， (6).

[3] 刘春华 . 汉字编码和输入法的应用统筹思考 [N]. 光明日报， 2007 年 4 月 1 日 .

（登录三合一汉字输入法网站： http://www.sanheyi.com ，可阅读作者更多有关汉字编码和输入法的文章，获取更多相关信息，并可自由下载免费开放的最新版三合一汉字输入法软件。）


 其它

This help file was created with the free trial version of HelpScribble.


 注册
除免费版外，三合一汉字输入法软件要求注册后使用。注册步骤如下：

1. 当提示"请注册后继续使用，谢谢！现在注册？……"时，点击"确定"。
2. 按照注册对话框的提示，通过邮件或短信或电话将您的软件系列号（显示在注册对话框中）和生产号（标注在《使用授权书》中）提供给我们，我们将据此为您提供注册码服务。获得注册码后，按照注册提示框进行注册，点击确定，完成注册。


e 时代的汉字梦

（刘春华）

二十世纪七十年代末期，中国，刚刚开启改革开放的序幕。突然间，承载五千年中华文明的古老汉字，一改往日的从容，变得手足无措——汉字无法进入计算机！

汉字，曾经失去过一个打字机时代。我们过来了，没什么感觉。

汉字，还可以失去电脑时代吗？这次不一样。君不见，信息化的时代列车陡然加速，风驰电掣，一日何止千里。中华民族决不能被远远抛在后面，永远承受“落后就要挨打”的命运。

汉字，前途未卜，“到了最危险的时候”！

1978 年，支秉彝博士公布中国大陆第一个小键盘汉字编码方案“见字识码”。此后，在中国大地，上演了一场“万码奔腾”的群众性科研大戏——上至白发苍苍的老专家，下至乳臭未干的中学生，成千上万的人们，以一种令人感动的热情，投入到汉字编码及键盘输入法的研制当中。一时间，编码方案如雨后春笋，层出不穷。

群众性活动难免鱼龙混杂，“万码奔腾”也曾遭非议，但是，这一幕是注定要载入史册了：中国“码”家军，成功破解了“汉字不能进入计算机”的咒语。

古老的汉字，没有阻挡中国信息化的步伐。

随着中国综合国力的不断增强，汉字在全世界的影响力还越来越大，“汉语热”正全球升温。

古老的汉字，又焕发青春，携文化强国之梦想，重装上阵！

但是，面对未来信息化的巨大挑战，面对随中国和平崛起而在世界范围掀起的“汉语热”，汉字，仍然没有做好准备：虽然汉字进入计算机早已不是问题，但迄今还没有一个理想的、统一的解决方案；汉字的排序和检索一如既往的效率低下，传统的部首查字法“一步三回头”，与拼音文字的直接翻页检索相比有天壤之别；虽然有争议，但世界上很多人认为汉字难学，而无所不能的电脑也在辅助汉字教学方面莫名其妙地失灵……

古老的汉字，穿越三千多年的时空，款款走来，在世界怀疑、惊讶的目光中，走进了电脑时代，但依然留下巨大的梦想空间。我们还需要构筑一条 e 时代的汉字之路，一条通向未来、通向世界的汉字之路。

让我们一起来畅想吧 ——

小学生，还有初学汉语的外国人，开始学习汉语拼音，可同步地用拼音输入汉字；

他们开始学习写字，又可用笔画输入汉字；

他们又学汉字部首了，就可同时用拼音、笔画和部首输入汉字；

无需切换，随心所欲，无级提速：输入速度与识字水平齐头并进，比翼双飞；

学生们毕业了，走向各行各业：有的成为职业录入员，需要高速盲打，有的研究源远流长的汉字文化遗产，面对数以万计的罕见字 …… 还好，从识字起就开始使用的输入法得心应手，完全满足各种职业要求；

汉字输入与识字同步，与语文基础教育一致，不但不是学习的负担，反过来成为辅助识字的工具，成为直通汉字王国的桥梁，借助电脑多媒体技术，使学习汉字成为一种乐趣；

汉字输入还与字典查字一致，实现如拼音文字一样的直接翻页查字；

……

带着中华民族深深烙印的方块汉字，饱含一种直达心灵的穿透力，一种怦然心动的美感，走出几千年历史沧桑，在闪烁现代化之光的电脑时代，走向世界，走向未来 ……

这是一个 e 时代的汉字梦，掠过我工作之余的时光。

曾经，我想学会一种编码输入法，但未入门就放弃了，因它坏了汉字之美。突然，毫无预兆地，一个念头一闪：不如自己设计一种输入法。

梦，发生了，不需要逻辑。

一种 “无知者无畏”的冒失，领我蹒跚走入梦境 ……

2003 年， 三易方案后，“三合一汉字编码及键盘输入法”悄然问世， 2005 年获中国发明专利授权。

……

红、黄、蓝，是美术绘画中的三原色。三原色按不同比例，可调配成各种不同的颜色，描绘出五光十色、万紫千红的世界。拼音、笔画、部首，是汉字世界的“三原色”—— 可尽显汉字的仪态万方、万千气象。三合一汉字编码及键盘输入法即是完全采用国家规范的汉语拼音、汉字笔画和汉字部首实施编码和输入，这是“三合一”的基本含义。集音码、音形码和形码（含笔画码）于一体，实现不切换、无障碍输入，这是“三合一”的第二个含义。汉字输入方法与汉字排序检索方法统一，并为电脑辅助识字奠定基础，这是“三合一” 的第三个含义。

这是一个需要梦想也产生梦想的时代。在美丽的梦想家园，有我的梦中情人，那就是 —— 三合一码，一种建立在汉字基础知识之上，应用拼音、笔画和部首，与识字同步、“无级变速”的汉字输入法；一种集音码、音形码和形码于一体，不切换混合使用的汉字输入法；一种可处理大汉字集直至全汉字集、通用于全社会的汉字输入法。

千年汉字入梦来。我的梦，骑一匹“码”，在 e 时代的汉字之路上，迅跑 ……